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RS Automation, Inc. 

Modbus Modicon F50 

 
 Supported version TOP Design Studio V1.4.3 or higher  

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 9 

 Describes how to set up communication for external devices. 

5. Cable table Page 10 

 Describes the cable specifications required for connection. 

6. Supported addresses Page 13 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “RS Automation, Inc. – Modbus Modicon F50” is as follows: 

 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

RS Automation Modbus Modicon F50 

RS-232C 

3. TOP communication 

setting 

4. External device setting 

5.1. Cable table 1 

RS-422(4 wire) 

3. TOP communication 

setting 

4. External device setting 

5.2. Cable table 2 

RS-485 (2 wire) 

3. TOP communication 

setting 

4. External device 

setting 

5.3. Cable table 3 

 

■ Connection configuration 

 

ㆍ1:1 (one TOP and one external device) connection – configuration which is possible in RS232C/422/485 communication. 

 

 

ㆍ1:N (one TOP and multiple external devices) connection – configuration which is possible in RS422/485 communication. 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “RS Automation”. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

Modbus Modicon F50 Serial MODBUS RTU 
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [Project > Project Property > TOP Setting] → [Project Option > “Use HMI Setup” Check > Edit > Serial] 

– Set the TOP communication interface in TOP Design Studio. 

 
 

 
 

Items TOP External device Remarks 

Signal Level (port) 

RS-232C 

RS-422 

RS-485 

RS-232C 

RS-422 

RS-485 

 

Baud Rate 38400  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [Project > Project Property > Device Setting > COM > “PLC1: Modbus modicon F50”] 

– Set the options of the Modbus modicon F50 communication driver in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface Select “Serial”. Refer to “2. External 

device selection”. Protocol Select “MODBUS RTU”. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Slave ID Enter the prefix of an external device.  
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [Main Screen > Control Panel > Serial] 
 

 

Items TOP External device Remarks 

Signal Level (port) 

RS-232C 

RS-422 

RS-485 

RS-232C 

RS-422 

RS-485 

 

Baud Rate 38400  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [Main Screen > Control Panel > PLC] 
 

 

Items Settings Remarks 

Interface Select “Serial”. Refer to “2. External 

device selection”. Protocol Select “MODBUS RTU”. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Slave ID Enter the prefix of an external device.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 
 

Configure the communication settings of the external device by referring to the vendor’s user manual. 
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this section may differ from the recommendations of “RS Automation.”) 
 

5.1 Cable table 1 

■ 1:1 connection (RS-232C) 

TOP COM Port (9 pin) 

COM 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1   

RD 2 SD 

SD 3 RD 

DTR 4 DTR 

SG 5 SG 

DSR 6 DSR 

RTS 7 RTS 

CTS 8 CTS 

 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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5.2. Cable table 2 

 

■ 1:1 connection (RS-422) 
 

TOP COM Port (9 pin) 

COM 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  SDA 

 2 SDB 

 3 RDA 

RDB 4 RDB 

SG 5 SG 

SDA 6  

 7  

 8  

SDB 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
 

 

■ 1:N connection – Refer to 1:1 connection to connect in the following way. 

 

TOP Cable connection and signal 

direction 

PLC Cable connection and signal 

direction 

PLC 

Signal name Signal name Signal name 

RDA 

 

SDA 

 

SDA 

RDB SDB SDB 

SDA RDA RDA 

SDB RDB RDB 

SG SG SG 
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5.3 Cable table 3 

■ 1:1 connection (RS-485)  

TOP COM Port (9 pin) 

COM 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  SDA 

 2 SDB 

 3 RDA 

RDB 4 RDB 

SG 5 SG 

SDA 6  

 7 

 8 

SDB 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

 

 

■ 1:N connection – Refer to 1:1 connection to connect in the following way. 

 

TOP Cable connection and signal 

direction 

PLC Cable connection and signal 

direction 

PLC 

Signal name Signal name Signal name 

RDA  SDA  SDA 

RDB SDB SDB 

SDA RDA RDA 

SDB RDB RDB 

SG SG SG 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use.  

 

 Bit Address Word Address R/W Remarks 

U0 0001.00 ~ 0017.15 0001 ~ 0017 R Inverter operation status 

U1 0101 .00~ 0115.15 0101 ~ 0115 R Operation status in case of abnormality 

U2 9920, 9922, 9924, 9926 9920, 9922, 9924, 9926 R/W Abnormality history 

U3 N/A N/A   Constant test record, communication does not allow R/W 

B0 1001 .00~ 1014.15 1001 ~ 1014 R/W Operation basic settings 

B1 1101.00 ~ 1103.15 1101 ~ 1103 R/W System initialization 

B2 1201 .00~ 1203.15 1201 ~ 1203 R/W Capacity, control mode setting 

F0 2001 .00~ 2009.15 2001 ~ 2009 R/W Frequency Command 

F1 2101 .00~ 2110.15 2101 ~ 2110 R/W Frequency Command Range Limit 

F2 2201 .00~ 2206.15 2201 ~ 2206 R/W Acceleration/deceleration time 

F3 2301.00 ~ 2304.15 2301 ~ 2304 R/W S Acceleration/deceleration time 

F4 2401 .00~ 2016.15 2401 ~ 2016 R/W Pattern operation setting 

S0 3001 .00~ 3004.15 3001 ~ 3004 R/W Direct brake function 

S1 3101 .00~ 3104.15 3101 ~ 3104 R/W Speed search function 

S2 3201.00 ~ 3204.15 3201 ~ 3204 R/W Dwell operation 

S3 3301 .00~ 3304.15 3301 ~ 3304 R/W Energy saving operation 

S4 3401.00 ~ 3403.15 3401 ~ 3403 R/W Slip correction 

S5 3501.00 ~ 3502.15 3501 ~ 3502 R/W Torque correction 

S6 3601.00 ~ 3603.15 3601 ~ 3603 R/W System error correction 

S7 3701.00 ~ 3721.15 3701 ~ 3721 R/W PID operation settings 

C0 4001.00 ~ 4008.15 4001 ~ 4008 R/W V/F settings 

C1 4101.00 ~ 4105.15 4101 ~ 4105 R/W Modification method 

C2 4201.00 ~ 4208.15 4201 ~ 4208 R/W Motor constant 

C3 4301.00 ~ 4310.15 4301 ~ 4310 R/W H/W adjustment constant 

H0 5001.00 ~ 5007.15 5001 ~ 5007 R/W Multifunction Input Contact 

H1 5101 .00~ 5106.15 5101 ~ 5106 R/W Multifunction Output Contact 

H2 5201.00 ~ 5213.15 5201 ~ 5213 R/W Multifunction Analog, pulse train input 

H3 5301 .00~ 5306.15 5301 ~ 5306 R/W Multifunction Analog, pulse train output 

H4 5401.00 ~ 5406.15 5401 ~ 5406 R/W Digital Operator settings 

P0 6001.00 ~ 6003.15 6001 ~ 6003 R/W Motor protection function 

P1 6101.00 ~ 6106.15 6101 ~ 6106 R/W Immediate power outage function 

P2 6201 .00~ 6206.15 6201 ~ 6206 R/W Stall prevention 

P3 6301.00 ~ 6303.15 6301 ~ 6303 R/W Excess torque detection 

P4 6401.00 ~ 6402.15 6401 ~ 6402 R/W Abnormal retry setting 

P5 6501.15 6501 R/W Fan Inspection Status 

P6 6601.15 6601 R/W PID constant 

EU 9900.00 ~ 9901.15 9900 ~ 9901 R Show error notation 

SU 9500.15 9500 R/W Device function status notation 

FreQ 9501.15 9501 R/W Communication frequency command 

Reset 9910.15 9910 W Clear fault 

 

 


