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TO BRI HE B X
Touch Qperation Panel

1. System configuration

The system configuration of TOP and “KEYENCE Barcode Series” is as follows:

Series Barcode Reader Communication method System setting Cable table
Barcode . 3. TOP communication

BL-1300 Series RS-232 B 4 Cable table

BL setting -

H Connection configuration
* 1:1 connection
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2. External device selection
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W Select a TOP model and a port, and then select an

external device.

Select Device

PLC select [COM1]

e [ g e —
@ Model (O Vendor

Vendor Model

DEVA & KV-10/16/24/40

CFTLCoN f@ KV-700/1000/3000/5000/7000/3000

TOHNICHI

Giddings & Lewis Motion Control
DELTA TAU Data Systems
Digital Electronics Corparation
HONEYWELL

MISUMI

PARKER HANMIFIN Corporation
TOSHIBA

ATLAS COPCO

TOSHIBA MACHINE Co., Ltd

GRFFN POWFR

& KV NANO Series

-,
" Barcode Reader BL Series

4_Back |

B Next *® Cancel

Select Device

PLC Setting[ Barcode Reader BL Series ]

Alias Name : |PLC1

Interface : | Serial

Protocol : |Keyence Barcode ~

[ use Redundancy

Primary Option

4

Comm Manual

Timeout 300 & | msec
Send Wait msec
Retry 5 =
Trigger I svs « [oooo0.00 (2T
oK v «|ooooo.01  [E|F
NG v +|ooooo.02 |
beta svs vfoowo [ 50 2] words
# Scan Error Message v
4@ Back « OK ® Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select "KEYENCE".
PLC Select the external device to be connected to the TOP.

Interface

KEYENCE Barcode

Serial

KEYENCE Barcode

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Option

B cranoe Hii

W 2cdric T Change PLCIC)

t-D TOP Setting I
" 520X

~ -l Option Module Setting
i g FieldBus (0)
-4 RFID (0)
W -1 Device Setting
~ 158 COM1 (1)

--fg® COM2 (0)
g COM3 (0)
-l Ethernet (0)
B8 Wireless (0)
- USBDevice (0)

i PLC1: Barcode Reader BL

Date [ Time Sync.
Project Option

Use HMI Setup
Hmi Setup Option

Screen Option

Screen Change

HmiSetup

EJ Delete pLCID]

Unit Convert

Global Lock & Touch Project Style  Splash

Initialization | Edit |

PLC Buffer Sync.

>

Project Setting
HMIDisable=0

Start Mode =Menu
Start Screen No.=1
Latch Use=0

Latch Set=0~0
Communication Error
USBErrorMessage=0

Project Name=New project

Message=0

StorageErrorMessage=1
DatabaseMessage=1

A

Control Panel

System m Devices

:ﬂ Service _F'"'_' Option

m Serial x
. =y
1! £ N serial Port: | COMT -
FLC Security Date/Time Signal Level
(® R3-232C O RS-422(4) O R5-485(2)
Baud Rate: 9600 v
(1] 0 —
NI | )/ Data Bit: 7 -
Et hernet Serial HOM 1 Stop Bit: 1 -
Parity Bit: Ewven v
BE= % Flow: |0ff
Rl O
[ Ping Auto Search  Loopback Test
Diagnost ic File Fing
Manager
Apply Cancel
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 9600
Data Bit 7
Stop Bit 1
Parity Bit Even
Items Description
Signal Level Select the serial communication method between the TOP and an external device.
Baud Rate Select the serial communication speed between the TOP and an external device.
Data Bit Select the serial communication data bit between the TOP and an external device.
Stop Bit Select the serial communication stop bit between the TOP and an external device.
Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [Project > Project Property > Device Setting > COM > "PLC1 : KEYENCE Barcode”]
— Set the options of the KEYENCE Barcode communication driver in TOP Design Studio.

Project Option X
- Change HMI[H] ' AddPLC[A] | THITal Change PLCial | [T Delete PLCID]
v {3 TOP Setting _ PLC Setting[ Barcode Reader BL Series ]
-} 5YS : RD1520%
# Option Module Setting Alizs Mame: : |PLC1 |
W Fieldgus (0) Interface : |Serial ~
g RFID (0)
v {4 Device Setting Protocol : |Keyence Barcode ~ Comm Manual
w
! | PLC1: Barcode Reader BI.]
coM3 () [] use Redundancy
W Ethernet (0) AMD e
& Wireless (0) - - -
@ USBDevice (0) . hd
G Edit
Primary Option
-
Timeout 200 &1 | msec
Send Wait msec
Retry
Trigger sys ~|ooooo.00 (3|55
OK 55 ~|ooooo.01 (355
NG 55 ~|oooo0.02 (3|55
fsta 55 + 00100 HiS Words
* Scan Error Message
W Message Input by Direct
- Message Scan Errar.
- Destination Data Address
Input a message from address
- Message ] « | DD200 : ;_3
= % - Destination 55 | 00300 :;3 = w
Apply Close
Items Settings Remarks
Interface Select “Serial". Refer to "2. External
Protocol Select “Keyence Barcode”. device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device. *Note 1)
SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device
and sending the next command request.
Retry Configures the number of attempts for data reception upon failure.

*Note 1) Configure it to be longer than the receive latency of the barcode scanner.
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Bl Communication interface setting
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Project Option

*
- Change HMI[H] ' AddPLC[A] | THTM) Change PLCIC | [] Delete PLCID]
v D TOP Setting _ PLC Setting[ Barcode Reader BL Series ]
L[} 5¥5: RD1520¥
v -l Option Module Setting Alias Name : |PLC1 |
W Fieldsus (0) Interface : | Serial s
Protocol : | Keyence Barcode s Comm Manual
W fg¥ COM1 (1)
-4 PLC1 : Barcode Reader BL
£59 COM2 (0)
£29% COM3 (0) [] use Redundancy
8 Ethernet (0) AND w
B9 Wireless (0) I - -
W USBDevice (0) T . i ) )
Edit
Primary Option
-~
Timeout 300 4| msec
Send Wait msec
Trigger 55 ~|oooo0.00 (5|55
OK sys ~|ooooo.01 (5|55
NG sys ~|ooo00.02 (2|5
Data svs 00100 HIS Words
# Scan Error Message
¥ Message Input by Direct
- Message Scan Error,
- Destination Data Address
Input a message from address
- Message ays 00200 H S
‘ - Destination avg + |D0300 2=l v
Apply Close
Items Settings Remarks
Trigger Configures the Bit address for executing Tag recognition.
OK Configures the enabled Bit address upon successful Tag recognition.
NG Configures the enabled Bit address upon failed Tag recognition.
Data

Configures the address and word length for entering Tag data.
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X Scan Error Message
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Enter designated message for “No tag” error

Message Input by Direct

Configure to enable or disable.

Message

Message

Destination

Enter to data storage address.

Enter reference message for “No tag” error

Input a message from address

Configure to enable or disable.

Message Message reference address

Destination Message input address

Size Configures the buffer size of the message reference/input Unit: word
address

X Tag Time Out Message

Enter designated message for “Tag read” error

Message Input by Direct Configure to enable or disable.

Message Message

Destination Enter to data storage address.

Enter reference message for “Tag read” error

Input a message from address Configure to enable or disable.

Message Message reference address

Destination Message input address

Size Configures the buffer size of the message reference/input Unit: word
address
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3.2. Communication setting in TOP

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

B [Main Screen > Control Panel > Serial]

Run

YNC
Yiewer

Screen
shot

Conitroll Panel

il Serial

15- Serial Port: lCDhﬂ "

Signal Level
® AS-232C () RS-422(4) () RS-485(2)

Baud Rate: l 9600 -

]
|
l
[‘;ITIII‘] cwms | © Data Bit: |7 -}
l
]

|
|
Stop Bit: | 1 -
|
|

PLC Security Dat

Ethernet Serial

i -

Parity Bit: | Even

-

Flow: | (¢

Diagnost ic File

- .lll

lAuto Searchl [Loopback Test]

[System] Close

[ Apply H Cancel ] —

Coese ||

R |
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 9600
Data Bit 7
Stop Bit 1
Parity Bit Even
* The above settings are setting examples recommended by the company.
Items Description
Signal Level Select the serial communication method between the TOP and an external device.
Baud Rate Select the serial communication speed between the TOP and an external device.
Data Bit Select the serial communication data bit between the TOP and an external device.
Stop Bit Select the serial communication stop bit between the TOP and an external device.
Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

Driver(COM1)

@ System

Run
Interface
‘ ] Protocol
FLC 3 Timeout

YHC Send Wait

Yiewer [lJ-I'ﬁ]
R T ,
] E Ethernet Trigger
. 0K

Data

Y Diagnost ic

Fetry

—

O Crvcnr bdamm -

ERI2 e B X
Touch Qperation Panel

TO,

e
o S101 PLC

PLC1(Barcode Reader BL Series) vl
| Serial R -

| Kevence Barcode R

300

msec

msec

i
[«

550 00000,00:1:16: DECR
S50 00000.07:1:1:DEC: W
S5 00000.02:1:1: DEC: W
5= 00100: 16:16: DEC: R

Words

—

[System] l Diagnostic [ App |y “Cancel l

Items Settings Remarks
Interface Select “Serial”. Refer to "2. External
Protocol Select “Keyence Barcode”. device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device. *Note 1)
SendWait (ms) Set the waiting time between TOP's receiving a response from an external device

and sending the next command request.
Retry Configures the number of attempts for data reception upon failure.
*Note 1) Configure it to be longer than the receive latency of the barcode scanner.
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and an external device.

- Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

- Check if the port (COM1/COM2/COM3) settings you want to use in [Control Panel > Serial] are the same as those of the external
device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].
- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system oK NG ) )
) ) - 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings OK NG
Relative prefix Project setting OK NG
Communication 2. External device selection
. . OK NG . -
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings oK NG . .
4. External device setting
Serial Parameter Transmission
oK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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TOP 225 -
4. Cable table

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of "KEYENCE Barcode”)

m KEYENCE Barcode (1:1 connection)

COM PORT RS-232C Port on CPU Unit
Pin Signal Pin Cable connection Pin Signal Pin
arrangement*Note 1) name number number name arrangement*Note 1)
1 5 CD 1 1 CcD 1 5
g g‘ sD 3 3 sD g g
Based on DTR 4 4 DTR Based on
communication SG 5 5 SG communication
cable connector DSR 6 6 DSR cable connector
front, RTS 7 7 RTS front,
D-SUB 9 Pin male cTs 8 8 cT1s D-SUB 9 Pin male
(male, convex) 9 9 (male, convex)

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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