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SIEMENS AG. 

SIMATIC S7-300/400 Series 

Ethernet Driver 
 Supported version TOP Design Studio V1.0 or higher  

 

 

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch Operation 

Panel (M2I TOP) Series". Read this manual and familiarize yourself with 

the connection method and procedures of the “TOP and external device”. 

 

 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of each 

device, cables, and configurable systems. 

2. External device selection  Page 4 

 Select a TOP model and an external device. 

3. TOP communication setting Page 5 

 Describes how to set the TOP communication. 

4. External device setting Page 10 

 Describes how to set up communication for external devices. 

5. Supported addresses Page 14 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “SIEMENS AG. – S7-300/400 Series Ethernet” is as follows. 

 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

SIMATIC 

S7-300 

CPU312 IFM 

CPU313 

CPU314  

CPU314 IFM  

CPU315  

CPU315(F)-2 DP  

CPU315(F)-2 PN/DP  

CPU316  

CPU316-2 DP  

CPU317-2 DP 

CPU317F-2 

CPU318-2  

CPU317-2 PN/DP  

CPU319-3 PN/DP 

CPU614 

CPU388 

CP 343-1 Lean 

CP 343-1 IT 

CP 343-1 

Ethernet  

TCP 

(OP Communication) 

3. TOP communication 

setting 

4.1. External device 

setting 1 

Twisted pair cable 

*Note 1) 

Ethernet 

TCP 

(FETCH/WRITE) 

3. TOP communication 

setting 

4.2. External device 

setting 2 

CPU315-2 PN/DP  

CPU317-2 PN/DP  

CPU319-3 PN/DP 

CPU built-in 

Ethernet port 

Ethernet  

TCP 

(OP Communication) 

3. TOP communication 

setting 

4.1. External device 

setting 1 

SIMATIC 

S7-400 

CPU412-1 

CPU412-2 DP 

CPU413-1 

CPU413-2 DP 

CPU414-1 

CPU414-2 DP 

CPU414-3 DP 

CPU416-1 

CPU416-2 DP 

CPU416-3 DP 

CPU417-4 

CPU414-3PN/DP  

CPU416-3PN/DP 

CPU417 

CPU486 

CP 443-1 Lean 

CP 443-1 IT 

CP 443-1 

Ethernet  

TCP 

(OP Communication) 

3. TOP communication 

setting 

4.1. External device 

setting 1 

Ethernet 

TCP 

(FETCH/WRITE) 

3. TOP communication 

setting 

4.2. External device 

setting 2 

CPU414-3PN/DP 

CPU416-3PN/DP 

CPU built-in 

Ethernet port 

Ethernet  

TCP 

(OP Communication) 

3. TOP communication 

setting 

4.1. External device 

setting 1 

*Note 1) Twisted pair cable 

- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5. 

- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a 

direct cable. 
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■ Connectable configuration 

 

ㆍ1:1 connection (one TOP and one external device) connection 

 

 

 

ㆍ1:N connection (one TOP and multiple external devices) connection 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 

 

 
 

  

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External 

device 

Vendor Select the vendor of the external device to be connected to TOP. 

Select “SIEMENS AG.” 

PLC Select the external device to be connected to the TOP. 
 

Model Interface Protocol 

S7-300/400 Series Ethernet  
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 

Supported Protocol 

OP Communication(COTP) Fetch/Write(SINEC-H1) 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project properties > TOP settings] → [Project option > Check “Use HMI settings” > Edit > Ethernet ] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 
 

Items TOP External device Remarks 

IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 

* The above settings are examples recommended by the company. 

 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 

 



 

 

External device connection manual for TOP Design Studio 6 / 15 

 

(2) Communication option setting 

■ [ Project > Project properties > PLC settings > ETHERNET > “PLC1 : S7-300/400 Series”] 

– Set the options of the communication driver of S7-300/400 Series Ethernet in TOP Design Studio 

 
* The above settings are examples recommended by the company. 

 

Items Settings Remarks 

Interface Select “Ethernet”. 
Refer to “2. External 

device selection”. 
Protocol Select the communication protocol between the TOP and an external 

device. 

Communication option items when selecting OP Communication 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of an external device.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external 

device and sending the next command request. 
 

Device name notation Set the device name display method.  

Communication option items when selecting Fetch/Write(SINEC-H1) 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external 

device and sending the next command request. 
 

Read TCP Port Enter the Ethernet communication read port number of the external device.  
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Write TCP Port Enter the Ethernet communication write port number of the external device.  

HMI TCP Port Enter the Ethernet communication port number of the TOP.  

Device name notation Set the device name display method.  

3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen.  

   

(1) Communication interface setting 

■ [ Main screen > Control panel > Ethernet ] 
 

 

 

Items TOP External device Remarks 

IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 

* The above settings are examples recommended by the company. 

 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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 (2) Communication option setting 

■ [ Main screen > Control panel > PLC ] 
 

 
* The above settings are examples recommended by the company. 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

Communication option items when selecting OP Communication 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of an external device.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external 

device and sending the next command request. 
 

Device name notation Set the device name display method.  

Communication option items when selecting Fetch/Write(SINEC-H1) 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external 

device and sending the next command request. 
 

Read TCP Port Enter the Ethernet communication read port number of the external device.  

Write TCP Port Enter the Ethernet communication write port number of the external device.  

HMI TCP Port Enter the Ethernet communication port number of the TOP.  

Device name notation Set the device name display method.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check whether the port (ETH1/ETH2) settings you want to use are the same as those of the external device in [Control Panel > 

Ethernet]. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

Check address range  

OK NG 

5. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 

4.1 External device setting 1 (OP Communication) 

Use SIEMETIC S7 Ladder Software [STEP 7] to set as follows. For more detailed setting method than described in this example, refer 

to PLC user manual. 
 

 
Do not use duplicate IP addresses over the same network. 

 

Step 1. Create a new project through [New Project] in the top bar of the main menu of [SIMATIC Manager]. 

Step 2. Select the Menu [Insert] > [Station] > [1 SIMATIC 400 Station] or [2 SIMATIC 300 Station]. ➔ Add CPU 

Step 3. Double-click the added “[SIMATIC 400(1)]” or [SIMATIC 300(1)] CPU > Double-click [Hardware] of the corresponding CPU. ➔ 

[HW Config] window is newly displayed. 

Step 4. Open “[SIMATIC 400] > [RACK-400]” or “[SIMATIC 300] > [RACK-300]” in the left tree window of the [HW Config] window to 

select the Base unit model to be used, and then drag & drop it to the lower right corner of the window to register. 

Step 5. Select [SIMATIC 400] > [PS-400] or [PS-300] to select the power unit to be used, and drag & drop it to the current rack. 

Step 6. Select [SIMATIC 400] > [CPU-400] or [CPU-300] to select the CPU unit to be used, and drag & drop it to the current rack. 

(If the [Properties – PROFIBUS interface DP] window is newly displayed, press the [Cancel] key to close the window.)  

◆ When setting CPU PN/IO, right-click [PN/IO] registered in X2 of CPU > Select [Object Properties…]  

→ [Properties] window is newly displayed. 

 

 

In case of using a communication card, select [SIMATIC 300] > [CP-300] or [SIMATIC 400] > [CP-400] to select the Ethernet 

communication unit to be used, and drag & drop it to the current rack. 

◆ When setting CP443-1 or CP343-1, right-click [Ethernet communication unit name] > Select [Object Properties…]  

→ [Properties] window is newly displayed. 

 

☞ Continued on next page. 
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Step 7. Click the [Properties] key of [General] tab > [Interface] in the [Properties] window. → Newly display the [Properties] window. 

Step 8. Enter the [IP address] and [Subnet mask] of the Ethernet communication module in the [Parameters] tab of the [Properties] 

window, and then click the [New...] key to register information. 

◆ For PN/IO ◆ For Ethernet communication module 

  

Step 9. Select the main menu [Station] > [Save And Compile] to save the error detection and setting, then download the settings to 

the PLC. 

Step 10. After the download is completed, reset the PLC power. 

  



 

 

External device connection manual for TOP Design Studio 12 / 15 

4.2 External device setting 2 (Fetch/Write(SINEC-H1)) 

Use SIEMETIC S7 Ladder Software [STEP 7] to set as follows. For more detailed setting method than described in this example, refer 

to PLC user manual. 
 

 
Do not use duplicate IP addresses over the same network. 

 

Step 1. Create a new project through [New Project] in the top bar of the main menu of [SIMATIC Manager]. 

Step 2. Select the Menu [Insert] > [Station] > [1 SIMATIC 400 Station] or [2 SIMATIC 300 Station]. ➔ Add CPU 

Step 3. Double-click the added “[SIMATIC 400(1)]” or [SIMATIC 300(1)] CPU > Double-click [Hardware] of the corresponding CPU. ➔ 

[HW Config] window is newly displayed. 

Step 4. Open “[SIMATIC 400] > [RACK-400]” or “[SIMATIC 300] > [RACK-300]” in the left tree window of the [HW Config] window to 

select the Base unit model to be used, and then drag & drop it to the lower right corner of the window to register. 

Step 5. Select [SIMATIC 400] > [PS-400] or [PS-300] to select the power unit to be used, and drag & drop it to the current rack. 

Step 6. Select [SIMATIC 400] > [CPU-400] or [CPU-300] to select the CPU unit to be used, and drag & drop it to the current rack. 

(If the [Properties – PROFIBUS interface DP] window is newly displayed, press the [Cancel] key to close the window.)  

Step 7. Select [SIMATIC 300] > [CP-300] > [Industrial Ethernet] or [SIMATIC 400] > [CP-400] > [Industrial Ethernet] to select an 

Ethernet communication unit, and drag & drop it to the current rack. → After drag & drop, [Properties] window is newly displayed. 

Enter the [IP address] and [Subnet mask] of the Ethernet communication module in the [Parameters] tab of the [Properties] window, 

and ehtn click the [New...] key to register information. 

 

Step 8. Select the main menu [Options] >[Configure Network]. → The network setting program “NetPro” is executed. 

Step 9. Register Fetch Passive (read port setting) and Write Passive (write port setting) on “NetPro”. 

◆ Fetch Passive (Read port setting) 

(1) Right-click CPU shown as a picture in “NetPro”, select [Insert New Connection], and pop-up the → [Insert New Connection] 

window. 

(2) Select [Type] > [TCP connection] and [Station] > [Unspecified] in the [Insert New Connection] window, and then click [OK]. 

→ [Properties] window is newly displayed. 

(3) In the [Properties] window, register IP and port in the [Address] tab, and [Mode] > “Fetch passive” in the [Options] tab. 

  

※(Caution) Do not duplicate the local port number. 
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(4) Click [OK] to save the settings.            ☞ Continued on the next page. 
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◆ Write Passive (Write port setting) 

(1) Right-click CPU shown as a picture in “NetPro”, select [Insert New Connection], and pop-up the → [Insert New Connection] 

window. 

(2) Select [Type] > [TCP connection] and [Station] > [Unspecified] in the [Insert New Connection] window, and then click [OK]. 

→ [Properties] window is newly displayed. 

(3) In the [Properties] window, register IP and port in the [Address] tab, and [Mode] > “Fetch passive” in the [Options] tab. 

  

※(Caution) Do not duplicate the local port number. 
 

(4) Click [OK] to save the settings. 

Step 10. Check the Fetch Passive / Write Passivesettings in the [Properties] > [Overview] tab. 

 

Step 11. Select the main menu [Station] > [Save And Compile] to save the error detection and setting, then download the settings 

to the PLC. 

Step 12. After the download is completed, reset the PLC power. 
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5. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

 
Bit address Word address 32 bits Remarks 

Input relay 

*Note 1) 

I00000.0 – 

I00127.7 

E00000.0 – 

E00127.7 

IW00000 – 

IW00126 

EW00000 – 

EW00126 

H/L 

*Note 4) 

*Note 5) 

— 

Output relay 

*Note 2) 

Q00000.0 – 

Q00127.7 

A00000.0 – 

A00127.7 

QW00000 – 

QW00126 

AW00000 – 

AW00126 

— 

Data block DB00001 : DBX00000 – 

DB65535 : DBX65533.7 

DB00001 : DBW00000 – 

DB65535 : DBW65532 

— 

Internal memory M00000.0 – M00511.7 MW00000 – MW00510 — 

Timer *Note 3) — T00000 – T00255 Cannot be written 

*Note 6) 

Counter *Note 3) — C00000 – C00255 Z00000 – Z00255 Cannot be written 

*Note 1) Input device (I, IW) is dependent on the built-in I/O according to CPU type, so Write input to the addresses of IW0 ~ IW2 may not be possible. Refer 
to PLC manual. 
*Note 2) Output device (Q, QW, QD) can enable Write value only in Run Mode. In Stop Mode, the output value is reset. 
*Note 3) Read-only device 
*Note 4) For word devices, 32-bit data is saved in the order of High/Low by 16 bits. 
(Example) VW00000 (32bit data, 0x12345678) ➔ VW00000(16bit, 0x1234) VW00002(16bit, 0x5678) 
*Note 5) When using 32 bit address, check the “word swap” function. 

*Note 6) Process it after turning the time base bit of S5TIME data OFF. 

 

 

 

 Not used Time base Time 0 ~ 999 

Bit 15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0 


