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1. System configuration 

The system configuration of TOP and “MINEBEA Co., Ltd. – Digital Indicator CSD Series Command Mode Serial” is as follows: 

 

Series Link I/F 
Communication 

method 

Communication 

setting 
Cable 

CSD-912B-EX 

CSD-912-EX 

CSD-903 

CSD-904-EX 

CSD-891B 

CSD-815B 

CSD-701B 

CSD-709 

CSD-819C 

CSD-401 

Serial port 
RS-232C 

RS-422/485 

3. TOP 

communication 

setting 

4. External device 

setting 

5. Cable table 

 

■ Connectable configuration 

 

ㆍ1:1 (one TOP and one external device) connection 
 

                     

 

 

ㆍ1:N (one TOP and multiple external devices) connection 
 

                       ∙∙∙  
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

Settings Contents 

TOP Model Check the display and process of TOP to select the touch model. 

External device Vendor Select the vendor of the external device. 

Select “MINEBEA Co., Ltd.”. 

External device Select external device. 
 

Model Interface Protocol 

Digital Indicator CSD Series Serial Command Mode 
 

 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project Property > TOP Setting ] → [ Project Options > “Use HMI Setup” Check > Edit > Serial ] 

– Set the TOP communication interface in TOP Design Studio. 
 

 
 

 

 

Items TOP External device Remarks 

Signal Level (port) RS-232C / RS-422 / RS-485 RS-232C / RS-422 / RS-485  

Baud Rate 115200  

Data Bit 8  

Stop Bit 1  

Parity Bit NONE  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [ Project > Project Property > PLC Settings > COM > “PLC1 : Digital Indicator CSD Series”] 

– Set the options of the Digital Indicator CSD Series Command Mode Serial communication driver in TOP Design Studio. 
 

 

 

Items Settings Remarks 

Interface Select “Serial”. 2. External device 

selection Protocol Select “Command Mode”. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next request. 
 

Address Set the external device communication address (prefix).  

Terminator Set the frame end code.  
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 
 

   

(1) Communication interface setting 

■ [ Main Screen > Control Panel > Serial ] 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-232C / RS-422 / RS-485 RS-232C / RS-422 / RS-485  

Baud Rate 115200  

Data Bit 8  

Stop Bit 1  

Parity Bit NONE  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [ Main Screen > Control Panel > PLC ] 
 

 

Items Settings Remarks 

Interface Select “Serial”. 2. External device 

selection Protocol Select “Command Mode”. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next request. 
 

Address Set the external device communication address (prefix).  

Terminator Set the frame end code.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 
 

Set the equivalent communication settings to that of the TOP by referring to MINEBEA Co., Ltd.’s user manual. 
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this section may differ from the recommendations of “MINEBEA Co., Ltd.”) 
 

■ RS-232C (1:1 connection) 

COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1    

 

RD 2 TXD 

SD 3 RXD 

DTR 4  

SG 5 SG 

DSR 6  

RTS 7  

CTS 8  

 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-422 (1:1 connection) 

COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA(+) 1  SDA(+)  

 2 SDB(-) 

 3 RDA(+) 

RDB(-) 4 RDB(-) 

SG 5 SG 

SDA(+) 6  

 7 

 8 

SDB(-) 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-485 (1:1 connection) 

COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA(+) 1  SDA(+)  

 2 SDB(-) 

 3 RDA(+) 

RDB(-) 4 RDB(-) 

SG 5 SG 

SDA(+) 6  

 7 

 8 

SDB(-) 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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■ RS-485 (1:1 connection) 

COM 

Cable connection 

External device 

Pin arrangement 
Signal 

name 

Signal 

name 
 

 

+  SDA(+)  

- SDB(-) 

SG RDA(+) 

 

RDB(-) 

SG 

 

 

■ RS-422 (1:N connection) – Refer to 1:1 connection to connect in the following way. 

TOP Cable connection and signal 

direction 

External device Cable connection and signal 

direction 

External device 

Signal name Signal name Signal name 

RDA(+) 

 

SDA(+) 

 

SDA(+) 

RDB(-) SDB(-) SDB(-) 

SDA(+) RDA(+) RDA(+) 

SDB(-) RDB(-) RDB(-) 

 

■ RS-485 (1:N connection) – Refer to 1:1 connection to connect in the following way. 

TOP Cable connection and signal 

direction 

External device Cable connection and signal 

direction 

External device 

Signal name Signal name Signal name 

RDA(+)  SDA(+)  SDA(+) 

RDB(-) SDB(-) SDB(-) 

SDA(+) RDA(+) RDA(+) 

SDB(-) RDB(-) RDB(-) 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

In TOP Design Studio, Digital Indicator CSD Series Command Mode Serial communication driver devices require entry of Command 

No. in CSD Command Mode. Refer to the manual of the model and use supported Command No. 

 

Address example) 

R20 : when reading data request Command No. 20 

R70/W80:01 : Function No. is 01, when reading data, request Command No. 70, write 80 

CMD50 : Command No. 50 Command transmission 

 

DEVICE BIT WORD R/W Remarks 

R20 - R20 R  

R21 - R21 R  

R22 - R22 R  

R23 - R23 R  

R24 - R24 R  

R25 - R25 R  

R26 

DATA - R26:DATA R  

STATUS1 R26:STATUS1.00~R26:STATUS1.04 R26:STATUS1 R *Note 1) 

STATUS2 R26:STATUS2.00~R26:STATU21.01 R26:STATUS2 R *Note 2) 

UNIT R26:UNIT.00~R26:UNIT.09 R26:UNIT R *Note 3) 

R30/W60 - R30/W60 R/W  

R31/W61 - R31/W61 R/W  

R32/W62 - R32/W62 R/W  

R33/W63 - R33/W63 R/W  

R34/W64 - R34/W64 R/W  

R35/W65 - R35/W65 R/W  

R36/W66 - R36/W66 R/W  

R37/W67 - R37/W67 R/W  

R38/W68 - R38/W68 R/W  

R39/W69 - R39/W69 R/W  

R40 R40.00 ~ R40.08 R40 R  

R41 R41.00 ~ R41.08 R41 R  

R42 R42.00 ~ R42.08 R42 R  

R43 R43.00 ~ R43.08 R43 R  

R45 R44.00 ~ R44.08 R44 R  

R46 R45.00 ~ R45.08 R45 R  

CMD50 CMD50 CMD50 W  

CMD51 CMD51 CMD51 W  

CMD52 CMD52 CMD52 W  

CMD53 CMD53 CMD53 W  

CMD54 CMD54 CMD54 W  

CMD55 CMD55 CMD55 W  

CMD56 CMD56 CMD56 W  

CMD57 CMD57 CMD57 W  

CMD58 CMD58 CMD58 W  

CMD59 CMD59 CMD59 W  

CMD5A CMD5A CMD5A W  
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DEVICE BIT WORD R/W Remarks 

CMD5B CMD5B CMD5B W  

CMD5C CMD5C CMD5C W  

CMD5D CMD5D CMD5D W  

CMD5E CMD5E CMD5E W  

CMD5F CMD5F CMD5F W  

CMD5G CMD5G CMD5G W  

CMD5H CMD5H CMD5H W  

CMD5I CMD5I CMD5I W  

CMD5J CMD5J CMD5J W  

R70/W80(8D) R70/W80(8D) : 00.00 ~ 99.31 R70/W80(8D) : 00 ~ 99 R/W 

*Note 4) 

R71/W81(8D) R71/W81(8D) : 00.00 ~ 99.31 R71/W81(8D) : 00 ~ 99 R/W 

R72/W82(8D) R72/W82(8D) : 00.00 ~ 99.31 R72/W82(8D) : 00 ~ 99 R/W 

R73/W83(8D) R73/W83(8D) : 00.00 ~ 99.31 R73/W83(8D) : 00 ~ 99 R/W 

R74/W84(8D) R74/W84(8D) : 00.00 ~ 99.31 R74/W84(8D) : 00 ~ 99 R/W 

R75/W85(8D) R75/W85(8D) : 00.00 ~ 99.31 R75/W85(8D) : 00 ~ 99 R/W 

R70/W80(10D) R70/W80(10D) : 00.00 ~ 99.31 R70/W80(10D) : 00 ~ 99 R/W 

*Note 5) 

R71/W81(10D) R71/W81(10D) : 00.00 ~ 99.31 R71/W81(10D) : 00 ~ 99 R/W 

R72/W82(10D) R72/W82(10D) : 00.00 ~ 99.31 R72/W82(10D) : 00 ~ 99 R/W 

R73/W83(10D) R73/W83(10D) : 00.00 ~ 99.31 R73/W83(10D) : 00 ~ 99 R/W 

R74/W84(10D) R74/W84(10D) : 00.00 ~ 99.31 R74/W84(10D) : 00 ~ 99 R/W 

R75/W85(10D) R75/W85(10D) : 00.00 ~ 99.31 R75/W85(10D) : 00 ~ 99 R/W 

R71/W70 R71/W70 : 00.00 ~ 99.31 R71/W70 : 00 ~ 99 R/W  

R79 -   R79 R  

R80 - R80 R  

R81 - R81 R  

R82 - R82 R  

R83 - R83 R  

R84 - R84 R  

R85 - R85 R  

R86 - R86 R  

R87 - R87 R  

 

*Note 1) R26:DATA must be registered on the same screen or read from the script to display normal data. 

Data when each bit is ON. (There could be differences among models.) 

Bit CSD- CSD-709 

0 OVERLOAD OVERLOAD 

1 STABLE TRACK 

2 UNSTABLE PEAK 

3  MEAS 

4  END 

 

*Note 2) R26:DATA must be registered on the same screen or read from the script to display normal data. 

Data when each bit is ON. (There could be differences among models.) 

Bit CSD- CSD-709 

0 NET PEAK 

1 GROSS TRACK 
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*Note 3) R26:DATA must be registered on the same screen or read from the script to display normal data. 

Data when each bit is ON. (There could be differences among models.) 

 

 

*Note 4) Request data in frames if the data is 8 digits or less. 

R70/W80 (8D): when entering is Function No. 

*Note 5) Request data in frames if the data is 10 digits or less. 

R70/W80 (10D): when entering is Function No. 

Bit CSD- CSD-709 

0 g g 

1 kg Kg 

2 t Lb 

3 lb T 

4 N N 

5 kN kN 

6  P 

7  kP 

8  MP 


