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GE Fanuc Automation 

Series 90-30/70  

Ethernet Driver 
 Supported version TOP Design Studio V1.0 or higher  

 

 

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 4 

 Select a TOP model and an external device. 

3. TOP communication setting Page 5 

 Describes how to set the TOP communication. 

4. External device setting Page 10 

 Describes how to set up communication for external devices. 

5. Supported addresses Page 14 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “GE Fanuc Intelligent Platforms, Inc. – Series 90-30/70 PLC, PACSystems RX3i/7i Series” is as 

follows. 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

Series 

90-30 

IC693CPU311 

IC693CPU313 

IC693CPU323 

IC693CPU331 

IC693CPU340 

IC693CPU341 

IC693CPU350 

IC693CPU351 

IC693CPU352 

IC693CPU360 

IC693CPU363 

IC693CSE311 

IC693CSE313 

IC693CSE323 

IC693CSE331 

IC693CSE340 

IC693CMM321 
Ethernet 

(TCP) 

3. TOP communication setting 

4.1. External device setting 1 

Twisted pair 

cable*Note 1) 

IC693CPU364 

IC693CPU374 

Ethernet interface  

on CPU unit 

Ethernet 

(TCP) 

3. TOP communication setting 

4.2. External device setting 2 

Twisted pair 

cable*Note 1) 

Series 

90-70 

IC697CPU731 

IC697CPU771 

IC697CPU772 

IC697CPU780 

IC697CPU781 

IC697CPU782 

IC697CPU788 

IC697CPU789 

IC697CPM790 

IC697CPM915 

IC697CPM925 

IC697CSE784 

IC697CSE924 

IC697CSE925 

IC697CPX772 

IC697CPX782 

IC697CPX928 

IC697CPX935 

IC697CGR772 

IC697CGR935 

IC697CMM742 

(Type2) 

Ethernet 

(TCP) 

3. TOP communication setting 

4.1. External device setting 1 

Twisted pair 

cable*Note 1) 

RX3i 

IC695CPU310 

IC695CPU320 

IC695NIU001 

IC695CMU310 

IC695CRU320 

IC695ETM001 
Ethernet 

(TCP) 

3. TOP communication setting 

4.3 External device setting 3 

Twisted pair 

cable*Note 1) 

RX7i 

IC698CPE010  

IC698CPE020 

IC698CRE020  

IC698CPE030 

IC698CRE030  

IC698CPE040 

IC698CRE040 

Ethernet interface 

on CPU 

Ethernet 

(TCP) 

3. TOP communication setting 

4.4. External device setting 4 

Twisted pair 

cable*Note 1) 
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*Note 1) Twisted pair cable 

- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5. 

- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a 

direct cable. 

■ Connectable configuration 

 

ㆍ1:1 connection (one TOP and one external device) connection 

 

 

 

ㆍ1:N connection (one TOP and multiple external devices) connection 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “GE Fanuc Automation”. 

PLC Select the external device to be connected to the TOP. 
 

Model Interface Protocol 

Series 90-30/70 Ethernet Ethernet (SRTP) 

 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project properties > TOP settings] → [Project option > Check “Use HMI settings” > Edit > Ethernet ] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 
 

Items TOP External device Remarks 

IP Address*Note 1) Note 2) 192.168.0.100 192.168.0.50  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 

* The above settings are examples recommended by the company. 

 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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(2) Communication option setting 

■ [ Project > Project properties > PLC settings > ETHERNET > “PLC1 : Series90-30/70”] 

– Set the options of the communication driver of Series 90-30/70 Ethernet(SRTP) in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select “Ethernet(SRTP)”. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of the external device   18245  . Fixed 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen.  

   

(1) Communication interface setting 

■ [ Main screen > Control panel > Ethernet ] 
 

 

 

Items TOP External device Remarks 

IP Address*Note 1) Note 2) 192.168.0.100 192.168.0.50  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 

* The above settings are examples recommended by the company. 

 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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 (2) Communication option setting 

■ [ Main screen > Control panel > PLC ] 
 

 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select “Ethernet(SRTP)”. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of the external device   18245  .  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- - Check whether the ETH port settings you want to use are the same as those of the external device in [Control Panel > Ethernet]. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

Check address range  

OK NG 

5. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 
 

4.1 External device setting 1 (IC693CMM321, IC697CMM742) 

Set as follows through Ladder Software “CIMPLICITY Machine Edition” for communication settings. For more detailed setting method 

than described in this example, refer to PLC user manual. After completing the settings, download the settings to the corresponding 

device. 
 

 
Do not use duplicate IP addresses over the same network. 

 

Step 1. Select [Project] – [Add Target] – [GE Fanuc Controller] – [Series 90-30 PLC] or [Series 90-70 PLC] in the main menu tool bar 

of [CIMPLICITY Machine Edition]. ➔Activate the “Target” you want to use.  

Step 2. Select [Right-click the corresponding “Slot”] – [Replace Module], [Add module…] to register “CPU unit” and “Ethernet 

Module” you want to use in [Target] – “Hardware Configuration” – “Main Rack” – corresponding “Slot” you want to use in the 

project tree of the [Navigator]. ➔ Select the Ethernet Module listed in the table below according to CPU Series. 

Contents Module Name 

Series 90-30 PLC IC693CMM321(Ethernet interface) 

Series 90-70 PLC IC697CMM742 (Ethernet Controller Type2) 

Step 3. Double-click the “Slot” where the “Ethernet interface Module” is registered. ➔The setting window is displayed. 

Step 4. Register the IP information in the [Settings] tab of the setting window as follows. 

 
 

Contents Settings Descriptions 

IP Address 192.168.0.50 
IP Information of the Ethernet Communication Module, 

Essential setting 

Subnet Mask *Note 1) 255.255.255.0 – 

Gateway IP Address *Note 1) 192.168.0.1 – 

Name Server IP Address *Note 1) 0.0.0.0 – 

*Note 1) This is not an essential setting. Keep the default value of “0.0.0.0” when not used. 
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4.2 External device setting 2 (Ethernet Interface on CPU Unit of Series 90-30/70) 

Set as follows through Ladder Software “CIMPLICITY Machine Edition” for communication settings. For more detailed setting method 

than described in this example, refer to PLC user manual. After completing the settings, download the settings to the corresponding 

device. 
 

 
Do not use duplicate IP addresses over the same network. 

 

Step 1. Select [Project] – [Add Target] – [GE Fanuc Controller] – [Series 90-30 PLC] or [Series 90-70 PLC] in the main menu tool bar 

of [CIMPLICITY Machine Edition]. ➔Activate the “Target” you want to use.  

Step 2. Select [Right-click the corresponding “Slot”] – [Replace Module] to register “CPU unit” you want to use in [Target] – 

“Hardware Configuration” – “Main Rack” – corresponding “Slot” you want to use in the project tree of the [Navigator]. ➔ When 

activated, the automatically registered CPU is changed and registered as the module you want to use. 

3. Double-click [Target] – “Hardware Configuration” – “Main Rack” – CPU to display CPU setting window. 

4. Register the IP information in the [Ethernet] tab of the setting window as follows. 

 
 

Contents Settings Descriptions 

IP Address 192.168.0.50 
IP information of the Ethernet Communication Module, 

Essential setting 

Subnet Mask *Note 1) 255.255.255.0 – 

Gateway IP Address *Note 1) 192.168.0.1 – 

*Note 1) This is not an essential setting. Keep the default value of “0.0.0.0” when not used. 

 

  



 

 External device connection manual for TOP Design Studio 12 / 14 

4.3 External device setting 3 (IC695ETM001) 

Set as follows through Ladder Software “CIMPLICITY Machine Edition” for communication settings. For more detailed setting method 

than described in this example, refer to PLC user manual. After completing the settings, download the settings to the corresponding 

device. 
 

 
Do not use duplicate IP addresses over the same network. 

 

Step 1. Select [Project] – [Add Target] – [GE Fanuc Controller] – [PACSystems RX3i] in the main menu tool bar of [CIMPLICITY 

Machine Edition]. ➔Activate the “Target” you want to use.  

Step 2. Select [Right-click the corresponding “Slot”] – [Replace Module], [Add module…] to register “CPU unit” and “Ethernet 

Module” you want to use in [Target] – “Hardware Configuration” – “Main Rack” – corresponding “Slot” you want to use in the 

project tree of the [Navigator]. ➔ Select the Ethernet Module listed in the table below according to CPU Series. 

GE Fanuc Controller Module Name 

PACSystems RX3i IC695ETM001 (Ethernet interface Module) 

3. Double-click the “Slot” where the “Ethernet interface Module” is registered. ➔The setting window is displayed. 

4. Register the IP information in the [Settings] tab of the setting window as follows. 

 
 

Contents Settings Descriptions 

IP Address 192.168.0.50 
IP information of the Ethernet Communication Module, 

Essential setting 

Subnet Mask *Note 1) 255.255.255.0 – 

Gateway IP Address *Note 1) 192.168.0.1 – 

Name Server IP Address *Note 

1) 
0.0.0.0 – 

*Note 1) This is not an essential setting. Keep the default value of “0.0.0.0” when not used. 
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4.4 External device setting 4 (Ethernet Interface on CPU Unit of RX7i) 

Set as follows through Ladder Software “CIMPLICITY Machine Edition” for communication settings. For more detailed setting method 

than described in this example, refer to PLC user manual. After completing the settings, download the settings to the corresponding 

device. 
 

 
Do not use duplicate IP addresses over the same network. 

 

Step 1. Select [Project] – [Add Target] – [GE Fanuc Controller] – [PACSystems RX7i]] in the main menu tool bar of [CIMPLICITY 

Machine Edition]. ➔Activate the “Target” you want to use.  

Step 2. Select [Right-click the corresponding “Slot”] – [Replace Module...] to register “CPU unit” you want to use in [Target] – 

“Hardware Configuration” – “Main Rack” – corresponding “Slot” you want to use in the project tree of the [Navigator]. ➔ When 

activated, the automatically registered CPU is changed and registered as the module you want to use. 

3. Double-click the Sub-node in the [Target] – “Hardware Configuration” – “Main Rack” – CPU Slot to display CPU setting window. 

4. Register the IP information in the [Settings] tab of the setting window as follows. 

 
 

Contents Settings Descriptions 

IP Address 192.168.0.50 
IP information of the Ethernet Communication Module, 

Essential setting 

Subnet Mask *Note 1) 255.255.255.0 – 

Gateway IP Address *Note 1) 192.168.0.1 – 

*Note 1) This is not an essential setting. Keep the default value of “0.0.0.0” when not used. 
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5. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

Device Bit Address Word Address Word Address NOTE 32 BIT 

Input Relay I00001 – I32768 I00001 – I32753 I00001 + 16*n *Note 1) 

L/H*Note 2) 

Output Relay Q00001 – Q32768 Q00001 – Q32753 Q00001 + 16*n *Note 1) 

Internal Relay M00001 – M32768 M00001 – M32753 M00001 + 16*n *Note 1) 

Global Relay G0001 – G7680 G0001 – G7665 G0001 + 16*n *Note 1) 

Momentary Relay T001 – T1024 T001 – T1009 T001 + 16*n *Note 1) 

System Function 

Relay 

S001 – S128 

SA001 – SA128 

SB001 – SB128 

SC001 – SC128 

S001 – S113 

SA001 – SA113 

SB001 – SB113 

SC001 – SC113 

S001 + 16*n *Note 1) 

Register R00001.0 – R32640.15 R00001 – R32640  

Analog Input AI0001.0 – AI32640.15 AI0001 – AI32640  

Analog Output AQ0001.0 – AQ32640.15 AQ0001 – AQ32640  

*Note 1) When using a bit address that uses decimals, use a word address in units of “16” 

*Note 2) The lower 16-bit data of 32-bit data is saved in the screen-registered address, and the upper 16-bit data is saved in the 

address following the screen-registered address. 

   Ex. When saving 32BIT data hexadecimal data 12345678 in address D00100, it is saved to 16BIT device address as follows: 

Items 32BIT 16BIT 

Address D00100 D00100 D00101 

Input data 

(hexadecimal) 
12345678 5678 1234 

 

 


