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DONGBU ROBOT CO,. LTD 

iMS-J Series  

Computer Link Driver 
 Supported version TOP Design Studio V1.0 or higher  

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 9 

 Describes how to set up communication for external devices. 

5. Cable table Page 10 

 Describes the cable specifications required for connection. 

6. Supported addresses Page 11 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “DongBu Robot Co,.Ltd – iMS-J Series Computer Link” is as follows. 

 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

iMS–J Series 
RS–422 

(4 wire) 

3. TOP communication 

setting 

4. External device 

setting 

5. Cable table 

 

 

 

■ Connection configuration 
 

ㆍ1:1 (one TOP and one external device) connection – configuration which is possible in RS232C/422/485 communication. 

 
 

ㆍ1:N (one TOP and multiple external devices) connection – configuration which is possible in RS422/485 communication. 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “Dongbu(DASAROBOT)”. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

iMS-J Series Computer Link Computer Link 
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project properties > TOP settings] → [Project option > Check “Use HMI settings” > Edit > Serial ] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 
 

Items TOP External device Remarks 

Signal Level (port) RS-422 RS-422  

Baud Rate 9600  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Project > Project properties > PLC settings > COM > “PLC1 : iMS-J Series”] 

– Set the options of the communication driver of DongBu Robot Co,.Ltd – iMS-J Series Computer Link in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface Select “Computer Link”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Station Num Enter the prefix of an external device.  
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [ Main screen > Control panel > Serial ] 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-422 RS-422  

Baud Rate 9600  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Main screen > Control panel > PLC ] 
 

 

Items Settings Remarks 

Interface Select “Computer Link”. Refer to “2. External 

device selection”. Protocol Select “Computer Link”. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Station Num Enter the prefix of an external device.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 

Refer to the manual of the external device to set the serial communication settings as follows (same as TOP serial communication 

settings). 

Items Settings 

Signal Level RS–422 

Baud Rate 9600 BPS 

Data Bit 8 BIT 

Stop Bit 1 BIT 

Parity Bit NONE 
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this chapter may differ from the recommendations of “DongBu Robot Co,.Ltd”.) 

 

■ RS-422 (1:1 connection) 

COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  1 RDA 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

 2 2 RDB 

 3 3 SDA 

RDB 4 4 SDB 

 5 5  

SDA 6 6  

 7 7  

 8 8  

SDB 9 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-422 1 : N connection - Refer to 1:1 connection to connect in the following method. 

TOP Cable connection and signal 

direction 

External device Cable connection and signal 

direction 

External device 

Signal name Signal name Signal name 

RDA 

 

SDA 

 

SDA 

RDB SDB SDB 

SDA RDA RDA 

SDB RDB RDB 

SG SG SG 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

Device Bit Address Word Address Read/Write Remarks 

Contact point IO00.0 ~ IO41.7 IO00 ~ IO41 Read/Write *Note 1) 

Integer variable INT00.00 ~ INT99.15 INT00 ~ INT99 Read/Write  

Position variable – POS000 ~ POS999 Read/Write *Note 2) 

Controller status STS0 ~ STS7 STS Read *Note 3) 

Function failure error 

i

n

f

o

r

m

a

t

i

o

n 

– MSG Read *Note 4) 

Speed – SPD Read/Write *Note 5) 

Current motion program file – JOB Read *Note 6) 

Current position – CRP0 ~ CRP1 Read *Note 7) 

Relative direct move – JOG Write *Note 8) 

Emergency stop EMG EMG Write *Note 9) 

Execute the motion program JOB_START JOB_START Write *Note 10) 

Stop the motion program JOB_STOP JOB_STOP Write *Note 11) 

Reset the motion program SYS_REBOOT SYS_REBOOT Write *Note 12) 

Return-to-origin execution MOVE_ORIGIN MOVE_ORIGIN Write *Note 13) 

Start jog movement (+) JOG_MOVE+ JOG_MOVE+ Write *Note 14) 

Start jog movement (–) JOG_MOVE– JOG_MOVE– Write *Note 15) 

Move the jog continuously JOG_CONTINUE JOG_CONTINUE Write *Note 16) 

End the jog movement JOG_STOP JOG_STOP Write *Note 17) 

 

*Note 1) Contact point device (IO) has two bytes constituting one word, and has L/H structure. The bit range is “0 - 7”. 
 

*Note 2) The position variable device (POS) is Float-type data. 
 

*Note 3) The bit information for the controller status (STS) is as follows. 

Bit Contents Bit Contents 

STS 0 Robot Run STS 4 Origin OK 

STS 1 In Position STS 5 Servo On 

STS 2 Motor Power STS 6 Exec Fail 

STS 3 Alarm STS 7 Seq Run 

 

*Note 4) When an error occurs in the controller, the code for the cause of the error is displayed. 
 

*Note 5) It displays the rotation speed when the motor is rotating. 

The data range that can be entered is a percentage value of RPM set to “1 - 100”. 
 

*Note 6) It displays the file name of the currently running motion program. It can be used only as a character string (12 characters). 
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*Note 7) It reads the current position of the controller. 

CRP Type Data Type 

CRP 0 Motor encoder pulse Decimal 

CRP 1 Distance (Joint) Float 
 

*Note 8) Relative direct move device (JOG) is Float-type data. 

It moves relative to the current position according to the type of motion, position type and position information. 

The input data range is –99999.999–99999.999. If it is out of range, the value is entered as the maximum or minimum value. 

*Note 9) Stop the controller in emergency situations. 

*Note 10) Execute the set motion program number. 

*Note 11) Stop the running motion program. 

*Note 12) Reset to the first step in step-by-step motion program execution. 

*Note 13) Execute returning to the start point. 

*Note 14) Start moving at the sped set in the jog speed parameter. (positive direction) 

*Note 15) Start moving at the sped set in the jog speed parameter. (negative direction) 

*Note 16) If executing continuous jog movement (JOG_CONTINUE) after starting jog movement (JOG_MOVE+,-), it moves 

continuously. 

*Note 17) Stop jog movement. 

 

※  Write-only Device   Use Method 

① Pop-up the object’s property window → ② Effects and actions → ③Condition setting → ④Action setting 

Set to enter data to the corresponding device when setting the action. (regardless of data value) 

 

 

 


