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SIEMENS AG.

SIMETIC S7 Series

ETHERNET(OP Communication) Driver
Compatible version OS Over 4.0

XDesignerPlus Over 4.0.0.0

CONTENTS  
Thank you for using M2I’s "Touch Operation Panel(M2I TOP) Series". Please read 

out this manual and make sure to learn connection method and process of TOP 

– External device”

1. System configuration Page 2

It explains device for connection, setup of, cable and structural system.

Please choose proper system referring to this point.

2. Selecting TOP model and external 

devices
 Page 4

Select TOP model and external device..

3. Example of system settings

Page 5

It explains setup example for communication connection between the 

device and external terminal. 

Select example according to the system you choose in “1. System 

structure”

4. Communication settings details Page 8

It explains the way of configuring TOP communication. 

If external setup is changed, make sure to have same setup of TOP with 

external device by referring to this chapter.

5. Support address Page 10

Check available addresses to communicate with external devices referring 

to this chapter.
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Series CPU Link I/F Method System settings Cable

SIMETIC

S7-300

CPU312 IFM

CPU313

CPU314 

CPU314 IFM 

CPU315 

CPU315(F)-2 DP 

CPU315(F)-2 PN/DP 

CPU316 

CPU316-2 DP 

CPU317-2 DP

CPU317F-2

CPU318-2 

CPU317-2 PN/DP 

CPU319-3 PN/DP

CPU614

CPU388

CP 343-1 Lean

CP 343-1 IT

CP 343-1

Ethernet

TCP

3.1 설정 예제 

13.1 Setting 

Example 1

( Page 5 )

Twisted pair 

cable*Caution1)

CPU315-2 PN/DP 

CPU317-2 PN/DP 

CPU319-3 PN/DP

CPU Integrated

Ethernet Port

SIMETIC

S7-400

CPU412-1

CPU412-2 DP

CPU413-1

CPU413-2 DP

CPU414-1

CPU414-2 DP

CPU414-3 DP

CPU416-1

CPU416-2 DP

CPU416-3 DP

CPU417-4

CPU414-3PN/DP 

CPU416-3PN/DP

CPU417

CPU486

CP 443-1 Lean

CP 443-1 IT

CP 443-1

CPU414-3PN/DP 

CPU416-3PN/DP

CPU Integrated

Ethernet Port

1. System configuration
TOP와 “SIEMENS AG – SIEMETIC S7 Series CPU ETHERNET(OP Communication)”의 시스템 구성은 아래와 같습니다.

*Caution1) Twisted pair cable

- This means STP(Shielded Twisted Pair cable) or UTP (Unshielded Twisted Pair cable) category 3,4,5.

- You can connect to configurational device such as hub, transceiver depends on the configuration and in this case, use direct cable.
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■ Possible Connecting Configuration

ㆍ1 : 1 connection(1 TOP and 1 External Device)

ㆍ1 : N Connection (1 TOP and several external devices) Connection
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Setting details Contents

TOP Series

Series Version name

XTOP / HTOP V4.0

Select the name of a TOP series that is to be connected to PLC.

Before downloading the settings, install the OS version specified in the table below according to 

TOP series.

Name Select the model name of TOP product.

External device Manufacturer Select the manufacturer of external devices to be connected to TOP.

Select “SIEMENS AG”.

PLC Select the model series of external devices to be connected to TOP.

Please choose “SIEMETIC S7 Series CPU ETHERNET(OP Communication)”. 

Please check, in the “1. System configuration”, if the relevant external device is available to set a 

2. Selecting TOP model and external devices
Select the external devices to connect to TOP.
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system configuration.
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Details TOP SIEMTIC S7 Series Remark

IP Address*Caution1)Caution2) 192.168.0.50 192.168.0.51 User settings

Subnet Mask 255.255.255.0 255.255.255.0 User settings

Protocol TCP TCP User settings

Port 2000 Read Port 102 User settings

Write Port 102

■  [ Project > Project property > Project > Settings > TOP Name ]

Set the communication interface of TOP tool.

- From right window [ HMI Setup > check Use HMI Setup > Device Manager ] 

- From right window [ HMI Setup > check Use HMI Setup > PLC Setup ]

■ External device settings

This sets the option of communication driver for “SIEMETIC S7 Series CPU ETHERNET(OP 

Communication)”.

- IP Address (PLC): Type the IP address that the external device was given.

-Reading port / writing port: Choose the port number that will be used for ethernet 

communication.

3. Example of system settings
The setup of communication interface between TOP and SIEMTIC S7 is recommended as below.

3.1 Example of settings 1

Set the system as below.

*Caution1) The network address (the 3 front digits of IP, 192.168.000) TOP and external device must be identical.

*Caution2) Please do not use the same IP address in the same network.

(1) XDesignerPlus setup

After setting the below details in [Project > Project Settings], download the detailed settings using TOP tool.
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Please do not use the same IP address in the same network.

(2) External device settings

Setup as below using SIEMTIC S7 Ladder Software STEP 7. Please refer the PLC user manual for more detailed information if you 

need.

1. Create a new project in [New Project] at upper bar of main menu of [SIMETIC Manager].

2. Select menu [Insert] > [Station] > [1 SIMETIC 400 Station] or [2 SIMETIC 300 Station]. → Add CPU

3. Double click added “[SIMETIC 400(1)]” or [SIMETIC 300(1)] CPU > Relevant CPU [Hardware] → New [HW Config] window appears.

4. Open “[SIMATIC 400] > [RACK-400]” or “[SIMATIC 300] > [RACK-300]” at left tree window in [HW Config], select Base unit model, 

and register it using Drag & Drop to the right bottom.

5. Select [SIMATIC 400] > [PS-400] or [PS-300] and then appropriate power supply unit, and drag & drop it to the current Rack.

6. Select [SIMATIC 400] > [CPU-400] or [CPU-300] and then appropriate CPU unit and drag& drop it to the current Rack.

(If [Properties] – PROFIBUS interface DP] windows appears, press [Cancel] to finish). 

◆ When CPU PN/IO setting, right click [PN/IO] which is registered on CPU의 X2 > select [Object Properties…] 

( A new [Properties] window will be appeared.)

If communication card is used, select additional [SIMATIC 300] > [CP-300] 혹은  [SIMATIC 400] > [CP-400] to choose ethernet 

communication unit that is being used and drag & drop on current rack.

◆ When setting CP443-1 or CP343-1, right click [Ethernet communication unit name] > Select [Object Properties…] 

( A new [Properties] window will be appeared.)

☞ Continue on the next page.
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◆ In case of PN/IO ◆ In case of Ethernet Communication Module

7. From [Properties] Tap [General] > Click [Properties…] in the [Interface]. ( A new [Properties] window will be appeared.)

8. From [Parameters] Tap in [Properties] window, input [IP address] and [Subnet mask] of Ethernet communication module, and click 

[New…] key to register the information.

9. Main Menu [Station] > select [Save And Compile] to error checking and save settings, download the saved information to PLC.

10. Reset the power of PLC after downloading.
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■  [ Project > Project property > Project > Settings > TOP Name ]

Set the communication interface of TOP tool.

- From right window, [ HMI Setup > check Use HMI Setup > Device Manager ] 

- From right window [ HMI Setup > check Use HMI Setup > PLC Setup ]

■ External device settings

This sets the option of communication driver for “SIEMETIC S7 Series CPU ETHERNET(OP 

Communication)”.

Details Contents

IP Address Setup the IP address that TOP receives in the network.

Subnet mask Input subnet mask of network

Gateway Input subnet mask of network

PLC IP address Input IP address that external device gets received.

Read Port / Write Port Choose port number that will be used for ethernet communication of external device.

TOP port Port number will be automatically setup if ethernet commucation with external device is in 

progress.

PLC address [0~65535] Address of other device. Select between [0 - 65535].

Ethernet time out Set up TOP’s waiting time from external device at [0 - 99] x 100mSec.

Delay time of transmission 

[ x1 mSec ]

Set up TOP’s waiting time between response receiving – next command request transmission 

from external device at [ 0 – 5000 ] x 1 mSec.

4. Communication settings details
Communication settings are available at XDesignerPlus or TOP main menu. Communication settings must be identical with the 

external devices.

4.1 XDesignerPlus settings details

 Select [Project > Project property] to show the below window.

■ Communication Interface Settings
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Protocol Choose the protocol type that are authorized to use following external devices and setup port 

number.
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PLC setup

PLC IP : 192 . 168 . 0 . 51 Communication Interface 

Protocol : TCP Settings

PLC Read Port : 102

PLC Write Port : 102

TOP Port : 2000

PLC Address : 00

Timeout : 1000 [mSec]

Delay time of transmission : 0 [mSec]

TOP IP : 192 . 168 . 0 . 50

 TOP Ethernet setting communication diagnosis

Details Contents

PLC IP It is an IP address that external device was given.

Protocol Choose the protocol type that are authorized to use following external devices and setup port 

number.

PLC Read Port It is the port address that will be used for ethernet of external device.

PLC Write Port It is the port address that will be used for ethernet of external device.

TOP port Port number will be automatically setup if ethernet commucation with external device is in 

progress.

PLC address [0~65535] Address of other device. Select between [0 - 65535].

Timeout [ x1 mSec ] Set up TOP’s waiting time from external device at [0 - 5000] x 1mSec.

Delay Time before 

transmitting [ x1 mSec]

Set up TOP’s waiting time between response receiving – next command request transmission 

from external device at [ 0 – 5000 ] x 1 mSec.

TOP IP Setup the IP address that TOP receives in the network.

Port Settings

* Ethernet Communication Ethernet Port

 + Network setting Communication Interface 

  - MAC : 00 - 15 - ID - 00 - 30 - 52  (each device has different address) Settings

  - IP Address : 192. 168 . 0 . 50

  - Subnet mask : 255 255 . 255 . 0

  - Gateway : 192 168 . 0 . 1

Details Contents

MAC Physical official address in the network.

IP Address Setup the IP address that TOP receives in the network.

Subnet mask An address that divides the network ID and host ID regarding of IP address.

Gateway An address that connects a network to another network.

4.2 TOP main menu setup item

 - When a buzzer is on during the power reset, touch 1 spot at the upper LCD to move to "TOP Management Main" display.

- Set up driver interface at TOP according to below Step1 → Step2.

(Press “TOP ethernet setup” in Step 1 to change setup at Step 2.)

Step 1. [ PLC setup ] - Setup driver interface.

Step 1–Reference.

Step 2. [PLC Setup] > [TOP Ethernet Setup] - Setup the serial parameter of correspond port.

Step 2–Reference.
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OK! Communication setting succeeded

Time Out Error! Communication setting error

- Error in the setting situation of Cable and TOP / External device

(reference : Communication Diagnosis sheet)

Details Contents Confirm

TOP Version Information xDesignerPlus : O.S : 

Name of Driver OK NG

External device 

information

IP Address
OK NG

(xDesignerPlus Subnet mask OK NG

Project setting) Gateway OK NG

TOP Information Protocol UDP/IP TCP/IP OK NG

(Main Device 

Menu Setting)

IP Address
OK NG

Subnet mask OK NG

Gateway OK NG

Other specified setting info OK NG

System 

configuration

System Connection Method
1:1 1:N N:1 OK NG

Name of cable (Hub usage) Direct (Use Hub) Cross (No Hub) OK NG

External 

device

Name of CPU
OK NG

Name of communication device OK NG

Protocol(mode) OK NG

Other specified setting info OK NG

IP Address (Local) (Destination) OK NG

Port number (Local) (Destination) OK NG

Subnet mask OK NG

Gateway OK NG

Address range confirm (other docs) OK NG

4.3 Communication diagnosis

■ TOP - Confirming interface setting condition between external devices 

- Move to Menu by clicking the top side of LCD screen as resetting the power of TOP.

- [Main Menu >Communication setting] Confirm if detail in number 20~24 is identical to the setup information of “■Setup exercise 

1”.

- PLC Setup > Click the button in "Communication diagnosis" of TOP Ethernet.

- Diagnosis dialog box will pop up on the screen, you can judge by following information that are shown on box no. 3 section.

■ Communication Diagnosis Sheet 

- Please refer to the information below if you have a problem between external devices and communication connection.
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Bit address Word address 32 bits Remark

Input Relay

* caution1)

I00000.0 –

I04095.7

E00000.0 –

E04095.7

IW00000 –

IW04095

EW00000 –

EW04095

H/L

*caution4caution5)

—

Output Relay

* caution2)

Q00000.0 

–

Q04095.7

A00000.0 –

A04095.7

QW00000 –

QW04095

AW00000 –

AW04095

—

Data Block DB00001 : DBX00000 –

DB65535 : DBX65533.7

DB00001 : DBW00000 –

DB65535 : DBW65532

—

Internal Memory M00000.0 – M08192.7 MW00000 – MW08192 —

Timer*caution3) — T00000 – T00255 Unavailable

to write

Counter*caution3) — C00000 – 

C00255

Z00000 – 

Z00255

Unavailable

to write

5. Support address
Devices that are usable with TOP is as below. 

There might be difference in the range of device (address) by type / series of CPU module TOP series supports the maximum 

address range that external device series use Please refer each CPU module user manual carefully for devices that you desired to use 

to prevent not getting out of range.

*Caution1) Input Device (I,IW) might not be able to input read on the address of IW0 ~ IW2 because depends on the type of CPU, it 

becomes subordinate in the integrated I/O. Please refer to the PLC Manual.

*Caution2) Output Device (Q, QW, QD) can write value only in the Run Mode. Output value will be reset if it's STOP Mode.

*Caution3) Device Restricted to Read only

For displaying the timer, use the calculatation tag, and then devide the timer value to two piece.

At the following example, the inner buffer 1001 means the current timer value and the inner buffer 1002 means the unit.

It means Unit) 0:10ms, 1:100ms, 2:1sec, 3:10sec

Display the inner buffer 1001, 1002.

*Caution 4) Regarding on Word device, 32 but Data will be saved in the order of from High / Low, 16 bit each.

(Example) VW00000 (32bit data, 0x12345678) è VW00000(16bit, 0x1234) VW00002(16bit, 0x5678)

*Caution5) Checks "Word Swap" function when 32BIT address is used.


