ASN INC.
ASN T&H Sensor

Serial Driver

Supported version TOP Design Studio V1.0 or higher {Rl

TOP

"

CONTENTS

We would like to thank our customers for using M2l's "Touch

Operation Panel (M2 TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

‘ Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. External device setting Page 9

Describes how to set up communication for external devices.

5. Cable table Page 10

Describes the cable specifications required for connection.

6. Supported addresses Page 11

Check for addresses that can communicate with an external

device.
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1. System configuration
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The system configuration of TOP and "ASN T&H Sensor” is as follows.

) ) Communication
NS Link I/F
method

Communication

setting

ASN T&H Main

Built-in RS-232C port RS-232C
Sensor Controller

3. TOP

communication
setting 5. Cable table

4. External device

setting

W Connection configuration

+ 1:1 (one TOP and one external device) connection
k(] .]

_
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H

PLC select [COM1]

Filter : |[AII] v‘ Search : I:I

@ Model (O Vendor

Vendor Model
~ -~

FANUC Co., Ltd. & SPEEDTECH : PUI-2000 Series
MINEBEA Co., Ltd. 83 JISANG : Rectifier
Azbil Corporation s

@7 ASN:TaHSensor
KORO TECHNOLOGY

& SN : Flow Meter
ROBOSTAR

SECRIM : PMC3000
Ebmpapst

& MEMORY MAP SLAVE
CoDeSys Automation Alliance

i .
Ophir Optronics Solutions Ltd. WILLINGS : Master

SERVOMEX, & SAMAHN TECH : Digital Air Speed Meter
Tiger Optics, LLC & Si TEC : MUX
B &R Automation & DONGDO TECH : ML Series
Peripheral Device & Human Automation : TSD
5
OTHERS Manufachure & On OF System : NEOS-HSD
v v
4_Back | B Next *® Cancel
Select Device [ = |

PLC Setting[ ASH : TH Sensor ]

Alizs Mame @ |PLCL

Interface : | Serial ~

Protocol : | ASN (Slave) ~ Comm Manual

[ use Redundancy

AND ~
Primary Option
@ Back + OK * Cancel
Settings Contents
TOP Model Check the display and process of TOP to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.

Select "OTHERS Manufacture > ASN T&H Sensor”

PLC Select an external device to connect to TOP.

Interface Protocol

ASN T&H Sensor Serial ASN (Slave)

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [ Project > Project properties > TOP settings] — [Project option > Check “"Use HMI settings” > Edit > Serial ]

— Set the TOP communication interface in TOP Design Studio.

Project Optien

-Change HMIH 'Add PLCIA | THITE Change PLCIC]

Date [ Time Sync.

3 TOP Setting
TD0s205

Screen Option

E3 Delete PLCID]

Unit Convert

HmiSetup  Global Lock & Touch  Project Style  Splash

Initialization | Edit |

PLC Buffer Sync.

h Option Module Setting Project Option  Screen Change
i FieldBus (0)
- RFID (0) se HMI Setup
~ g Device Setting —
g8 COM1 (1) R R
i L4 PLC1: ASN : T&H Sensor Project Setting
HMIDisable=0

Project Name=New project
Start Mode=Menu

Start Screen No, =1

Latch Use=0

Latch Set=0~0

Communication Error Message =0
USBErrorMessage =0
StorageErrorMessage=1
DatabaseMessage=1

Ethernet (0)
[ Wireless (0)
i USBDevice (0}

~

Control Panel

System I:= Devices

:"aService =% option

s Serial *
S =
g l £~ Serial Port:  COM1 -
PLLC Security Dat e/ Time Signal Level
@) R5-232C O RS-422(4) O R5-486(2)
Baud Rate: 115200 =
(] o —
1T el ) Data Bit: 8 .
Et hernet Serial HOK | Stop Bit: 1 =
R Parity Bit: MNone -
- % Flow: [ff
el O
Disgrost ic Fils Ping Auto Search  Loopback Test
Manager
Apply | Cancel
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 115200
Data Bit 8
Stop Bit 1
Parity Bit None.

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [ Project > Project properties > PLC settings > COM > “"ASN T&H Sensor”]

Set the options of the communication driver in TOP Design Studio.
Project Option X

B cranoe i W ~capcial | S Chengepicia) | [ Dekete PLCD]

w -] TOP Setting

"3 svs : RDOB20S PLC Setting[ ASN : TH Sensor ]

{8 Option Module Setting Alias Name : [PLC1
- ::;;EEIDS) @ Interface : | Serial ~ Impart Address
Ce
v i Device Setting Protocol : | ASN (Slave) R Comm Manual

jogt®
¢ Jwm piCt: ASN: T8H Sensor|
[ ey

5% COM3 (0} [ use Redundancy
8 Ethernet (0) AND ~
5 Wireless (0) - =

-4 USBDevice (0)

Primary Cption

@B ASN Tag - O X
Add Count : 1l o 2dd 9 Delete
Address TAG Description L]
1 [5YS: 137777376: 16] ~ [5YS: 137777375: 16] 00000000
2 [5¥5:137777370:18] ~ [5YS5:137777375:16] 00000000
3 [E¥5:137777376: 18] ~ [5YS:137777375:16] 00000000
4 [E¥5:137777376: 18] ~ [5YS:137777375:16] 00000000
5 [BY5:137777375:18] ~ [5YS:137777375:16] 00000000
& [BY5:137777375:18] ~ [5YS:137777375:16] 00000000
7 [SY5: 137777376: 18] ~ [5Y5: 137777375: 18] 00000000
B [SY5: 137777376: 18] ~ [5Y5: 137777375: 18] 00000000
9 [SY5: 137777376: 18] ~ [5Y5: 137777375: 18] 00000000
10 [SY5: 137777376: 18] ~ [5Y5: 137777375: 18] 00000000
11 [SY5: 137777376: 18] ~ [5Y5: 137777375: 18] 00000000
12 [SY5: 137777376: 18] ~ [5Y5: 137777375: 18] 00000000
13 [SYS: 137772376 16] e [5Y5: 137777375: 16] nnOnnANN hd
Total Count : 15 Ok Close
Items Settings Remarks
Interface Configure the communication interface between the TOP and an external device. Refer to "2. External
Protocol Configure the communication protocol between the TOP and an external device. device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and

sending the next command request.

Import Address Address: Incremented by 100 words for each addition, use 70 words per tag.

Tag: Enter the tag number.

Description: Enter a desription for each tag.
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3.2. Communication setting in TOP

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting
M [ Main screen > Control panel > Serial ]

Gontroll Panel

o e sernal

Serial Port: | COMI

Signal Level
@ RS-232C O RS-422(4) O RsS-485(2) ]

Run
7
PLC Baud Rate: [ 115200 I']

Viwer - Data Bit: |8 B
] | - Stop Bit: || B

Ethernet Serial Parity Bit: [ None |v]
Flow: [ Of f |']

[Auto Searchl [Loopback Test]

Diagnostic File
Manager

[ Apply H Cancel ‘

[System] Close

TOPRX - TOPRX0800S A  2021-08-31 02:01:56 PH
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 115200
Data Bit 8
Stop Bit 1
Parity Bit None.

* The above settings are setting examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

W [ Main screen > Control panel > PLC ]

¥YNC
Yiewer

TOPRX - TOPRX0800S

£ | ) PLGC

@ Systen | Driver(COMT) | PLCICASN : T8H Sensor) |~/
Interface | Serial v
‘ Protocol | 43N (Slave) |

l
|

)

PLC

L

i

Ethernet

fon

T

Diagnost ic

ERI2 e B X
Touch Qperation Panel

[System] [ Diagnostic [ pp |y ”Cancel ]

]

2021-08-31 03:05:-41 PH

Items Settings Remarks
Interface Configure the communication interface between the TOP and an external device. Refer to "2. External
Protocol Configure the communication protocol between the TOP and an external device. device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device and

sending the next command request.

ImportAddress

You can add or remove tags.

When holding down the top of the screen and draging it down during the run, a
pop-up window will appear.

Press the EXIT button to exit the menu mode.

Click Desktop > Control panel > Communication device > PLC > Import Address

(picture above) to add/delete/modify tag information.
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC ].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information oK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG . .
diagnostics 3. Communication setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
oK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

For more detailed setting methods than described in this example, please refer to the user manual of ASN.

Step 1. Add tag information

88 ASN Tag — O X
Add Count : 113 o Add 3 Delete
Address TAG Description

) | [SYS:00000:16] ~ [SYS:00069:16] 00000000
2 [SYS:00100:16] ~ [SYS:00169: 16] 00000001
3 [SYS:00200:16] ~ [SYS:00269:16] 00000002
4 [SY5:00300: 16] ~ [5Y5:00369: 16] 00000003
5 [SYS:00400:16] ~ [SYS:00469:16] 00000004
6 [5Y5:00500: 16] ~ [SY5:00569: 16] 00000005
7 [SYS:00600:16] ~ [SYS:00669:16] 00000006

Total Count: 7 Ok Close

Step 2. How to write a project

50997 GH | JKLMNOPORSTUVWXY 22222 ~GH [ JKLMNOPQRSTUYWXY Z

FRRR
LS

GH | JKLMNOPQRSTUYMWXY 22277

00227:GHIJ
ZEIGHI

s
F\

~
0
~

YS:
-

YS!
U

Er5:00342:GHIJ
[5Y5:00252:GHI J SY5:00352:GHI )

Rl 1'GHIJ

The address of the character Object that describes the tag uses (SYS:0, SYS:100, SYS:200...) entered in Import Address. The length of
the character can be up to 40 English characters.
Refer to the following table for the address of the numeric Object representing the sensor value, and the character Object

representing the sensor unit.

Sensor value

SYS address of numeric Object

Sensor unit

SYS address of character Object

Sensor 1 value

Start address of the tag + SYS:20

Sensor 1 unit

Start address of the tag + SYS:22

Sensor 2 value

Start address of the tag + SYS:30

Sensor 2 unit

Start address of the tag + SYS:32

Sensor 3 value

Start address of the tag + SYS:40

Sensor 3 unit

Start address of the tag + SYS:42

Sensor 4 value

Start address of the tag + SYS:50

Sensor 4 unit

Start address of the tag + SYS:52

Sensor 5 value

Start address of the tag + SYS:60

Sensor 5 unit

Start address of the tag + SYS:62

Each tag is assigned in units of 100 SYS addresses.
One tag can have up to 5 sensor values.
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The numeric Object representing the sensor value is set as a Float type.
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88 Mumeric Property X
PREVIEW i
Data Shape Style Input Case Effect & Action
Feature
- 123 . 45 o (123 123] [ABC 123 -
Numeric[M] 7 Segment[G] String[S] Input Display[D] Clodk[K]
Address
Display Address : SYS 1l00020 ]: o
Type: |[FLOAT v Size : 32Bit
Select a character string for the character Object representing the sensor unit, and enter 10 for the number of strings.
88 String Property X
PREVIEW .
Data Shape Style Input Case Effect & Action
Feature
ABCDE FGHIJ [123 123] o [ABC 123 E
Numeric[N] 7 Segment[G] String[S] Input Display[D] Clock[K]
Address
Display Address : sYsS v 000 ‘: T E
= o Max String Length[L] : |10 +1| []Byte Swap[B] [TJuse Korean
Step 2. Project execution screen
MUX: Temperature & Humidity SHTZ20: Temperature & Humidity
-30.0 Temp( C) 27.0 Temp("C)
28.2 Humi(%d) 27.8 Humi (%d)
0.0
0.0
3.0 Vatt(V) 3.0 Vatt(Vv)
Temperature (decimal) Temperature (integer3)
26.7 Temp('C) -16.0  Temp("C)
5.0 Temp('C)
43.0  Temp( C)
0.0
2.5 Vatt(V) 2.5  Vatt(V)
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5. Cable table
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This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

W RS-232C (1:1 connection)

COM Main Controller
Pin Signal Pin Cable connection Pin Signal Pin
arrangement*Note 1) name number number name arrangement*Note 1)
1 5 RS422 1 1
o L T
O
g 3 XD 3 3 XD Based on
communication
Based on RS422 4 4
cable connector
communication SG 5 5 SG front
RS422 6 6 ront
cable connector D-SUB 9 Pin male
front, 5V 7 7
(male, convex)
D-SUB 9 Pin male GND 8 8
(male, convex) RS422 9 9

*Note 1) The pin arrangement is a view looking at the connection side of the cable connector. Do not connect pins not to be used.
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6. Supported addresses

It can be used within the allowable range of TOP internal address 0 ~ 10239.
You can import and use up to 102 RF TAG sensors.
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