LS MECAPION Co., Ltd.
ANYPACK Servo Drive Series

Computer Link Driver

Supported version TOP Design Studio V1.0 or higher ’R

TOP

"

CONTENTS

We would like to thank our customers for using M2I's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of
each device, cables, and configurable systems.

Please refer to this section and select the appropriate system.

2. External device selection Page 3

Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.
When changing external device settings, refer to this section

and set identical TOP communication settings.

4. External device setting Page 9

Describes how to set up communication for external devices.

5. cable table Page 10

Describes the cable specifications required for connection.

1. Choose appropriate cable specification according to system

chosen in “System configuration.”

6. Supported addresses Page 11

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of TOP and “LS MECAPION Co., Ltd. — ANYPACK Servo Drive Series Computer Link” is as follows:

Communication

Series ‘ Link I/F System setting ‘

method
3. TOP

APD-VS[LI[] -

communication
APD-VPLI] CN3 Port -

APD ) RS-232C setting 5. Cable table

APD-VK[CI] on CPU unit )

4. External device
APD-VNUII

setting

B Connection configuration

+ 1:1 (one TOP and one external device) connection — configuration which is possible in RS232C communication.
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H
PLC select [COM1]
Filter : |[AII] v‘ Search : I:I

@ Model (O Vendor

Vendor
BACnet L

LS MECAPION

HIGEN MOTOR Co., Ltd.

EMOTIONTEK

RKC Instrument Inc.
HANYOUNG NUX
SAMWONTECH

SICK AG.

FUJI Electric Co., Ltd.
SANGII Predsion Co., Ltd.
DEVA

OPTICON

TOHNICHT

Giddinns & | ewis Mation Contral

4_Back | B Next *® Cancel

Select Device [ = |
PLC Setting[ Anypack Series ]
Alizs Mame @ |PLCL
Interface : | Computer Link ~
Protocol : | C-MET ~ Comm Manual

String Save Mode : |First LH HL Change

[ use Redundancy
AND v

Primary Option

Timeout msec
Send Wait msec

Station Num
Write Function Block Write
@ Back + OK * Cancel
Settings Contents

TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.

Select “LS MECAPION (Metronix)".

PLC Select an external device to connect to TOP.

Interface Protocol

Anypack Series Computer Link C-NET

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

W [Project > Project Property > TOP Setting] —

— Set the TOP communication interface in TOP Design Studio.

[Project Option > “Use HMI Setup” Check > Edit > Serial]

Project Option

- Change HMI[H]

TOP Setting

W Ao pic Tl Change FLCIC]

E3 Delete PLCIDY

0 ove  AD1520% Date / Time Sync. = Screen Option = Unit Convert
h -Opﬁ”_” Modle Setting Project Option  Screen Change = HmiSetup | Global Lock & Touch  Project Style  Splash  PLC Buffer Sync.
W FieldBus (0)
= RFD (0) Use HMI Setup
M 'E-Eivieozit?:f TR nitialization | Edit |
-4 PLC1 : Anypack Series [0] Project Setting A
~fg¥ COM2 (0) HMIDisable=0
- gl COM3 (0) Project Ndame’vI:New project
thernet (0) Start Mode=Menu
; Svlralesst[t?) f?t;icsrsig Ne.=1
-4 USBDevice (0) Latch Set=0~0
Communication Error Message =0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1
Caontrol Panel
. | . = E .
System m Devices .? Service |~ Option
i Serial *
.
| ~| Serial Port: COMI -
PLLC Security Dat e/Tim Signal Level
(®) BS-232C () RS-422(4) () RS-485(2)
Baud Rate: 38400 <
o o e
"I"" —- '\__/ Data Bit: |3 -
Et hernet Serial HOM | Stop Bit: 1 -
Parity Bit: None v
I ; \ Flow: [ff
. L_ A Ping
: . Auto Search  Loopback Test
Diagnost ic File Ping
Manager
Apply | Cancel
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 38400
Data Bit 8
Stop Bit 1
Parity Bit None.

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [Project > Project Property > Device Setting > COM1 > “PLC1 : Anypack Series"]
— Set the options of the LS MECAPION Co., Ltd. — ANYPACK Series Computer Link communication driver in TOP Design

Studio.

Project Option

- Change HMIH]

' AddPLC[A] | THITal Change PLCIC)

m Delete PLC[D]

~ [} TOP Setting
| L[ 5Y5:RD1520%
Option Module Setting
8 FieldBus (0)
- RFID (0)
W - Device Setting

LV - fala AN AL

PLC Setting[ Anypack Series ]
Alizs Name : [PLC1

Interface : | Computer Link ~

Protocol : | C-NET ~

- PLC1: Anypack Series [0]

String Save Mode : (First LH HL

:

Change

i COMZ (0]

=% COM3 (0)
W Ethernet (0)
® Wireless (0)

L. USBDevice (0)

[ use Redundancy

§
5]
4

Primary Option
Timeout 200 &1 | msec
Send Wait
Station Num

‘Write Function

Block Write w

b

Comm Manual

Apply Close
Items Settings Remarks
Interface Select "Computer Link". Refer to "2. External
Protocol Select the communication protocol between the TOP and an external device.

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device

and sending the next command request.

Station Num

Enter the prefix of an external device.

Write Function

Configure the write command.
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3.2. Communication setting in TOP

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Gontrol Panell
o e Serral

@ System De

tun | Serial Port: | COM1 -
n | Signal Level
‘ ‘ ® RS-232C () RS-422(4) () RS-485(2)

PLC Security Baud Rate: [ 38400

Uive“'[;r " - Data Bit: [ 8 i
] | - Stop Bit: [] "

FE=ay

: Ethernet Serial Parity Bit: [ Nore i'

- Flow: [Off iv

Screen

[Auto Search] [Loopback Test]

[

Diagnost ic File
Manager

[ Apply ”Cancel ]

[System] Close

TOPRX - TOPRX0800S A  2021-08-31 02:01:44 PH
Items TOP External device Remarks
Signal Level RS-232C
(port) RS-232C
Baud Rate 38400
Data Bit 8
Stop Bit 1
Parity Bit None.

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device. (COM3 supports only RS-485.)
Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

B [Main Screen > Control Panel > PLC]

Sl PILC
@ Driver(COM1) | PLCT(Anypack Series) |~/
System :
Run Interface | Computer Link B3
m Protocol | C-MNET |~
‘ Timeout 1300 |3 msec
PLC

Send Wait msec

¥YNC

Yiewer [,I'L,] Retry g
(1] Station b O

. Ethernet Write Fur Block Wi~
-

" '_:,"
\Smen | m ;
- Diagnost ic
[ Diagnostic [ AppIyHCanceI”
[System]

TOPRX - TOPRX0800S 2021-08-31 03:02:47 PH
Items Settings Remarks
Interface Select “Computer Link". Refer to "2. External
Protocol Select the communication protocol between the TOP and an external device. device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP's receiving a response from an external device

and sending the next command request.

Station Num Enter the prefix of an external device.

Write Function Configure the write command.
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the port (COM1/COM?2) settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information oK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG . .
diagnostics 3. Communication setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
oK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

Refer to the manual of the external device and configure the servo drive system parameters as follows.

W System Parameter [PE-202] : Transmission speed configuration

Items Settings Contents

[PE-202] 2 38400 [bps]

W System Parameter [PE-202] : Transmission speed configuration

Items Settings Contents

[PE-207] 0 Prefix (Station ID) "0" configuration
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5. Cable table

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of “LS MECAPION Co., Ltd.")

W RS-232C (1:1 connection)

COM Port Servo Drive (CN3 port)
Pin Signal Pin Cable connection Pin Signal Pin
arrangement*Note 1) name number number name arrangement*Note 1)
1 5 CD 1
. ) R e RO g |[ |1
Q S SD 3 6 TXD
6 9
Based on DTR 4 l
_ SG 5 8
communication
cable connector DSR 6 9 14 =
front RTS 7 10 B |
D-SUB 9 Pin mal cTS 8 11 SG
n maie 10114-3000VE(3M)
(male, convex) 9 12 SG

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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6. Supported addresses

The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the
address range supported by the device you want to use.

i:ﬁ — For address input, enter the “Communication Code”listed in the description in the external device manual.
MENU Unit Initial value
Communication
CODE NAME Min Max
Code

Export range for completed positionin Pulse 100

100 PE-501 P J - P P 9
Inposition 0 99999

— For external device (MD) data size, 32 bits is standard.

Device Bit address Double word address Remarks

Menu Data MD0000.00 - MD9999.31 MDO0000.00 — MD9999.31
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