Atlas Copco
POWER FOCUS

Ethernet Driver

Supported version TOP Design Studio V1.4.11.18 or higher{Rl
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We would like to thank our customers for using M2l's "Touch Operation

Panel (M2 TOP) Series". Read this manual and familiarize yourself with
the connection method and procedures of the “TOP and external

device”.
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‘ Describes connectable devices and network configurations.
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‘ Select a TOP model and an external device.
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5. Supported addresses Page 10

Describes the addresses which can communicate with an external

device.
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1. System configuration

The following driver is "POWER FOCUS" of "ATLASCOPCO".
The system configuration with an external device supported by this driver is as follows:

Communication

Series CPU Link I/F System setting Cable
method
3. TOP
Ethernet .
POWER FOCUS communication *Note 1)
(TCP) )
setting

*Note 1) Twisted pair cable
- Refers to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5.
- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a

direct cable.

W Connectable configuration
+ 1:1 connection (one TOP and one external device) connection

B

T

* N:1 connection (multiple TOPs and one external device) connection

HUOB
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2. External device selection

H Select a TOP model and a port, and then select an external device.

PLC select [Ethernet]

Filter : |[AII] v‘ Search : I:I

@ Model (O Vendor

Vendor Model
PATLITE L

Giddings & Lewis Motion Control
DELTA TAU Data Systems
KEYENCE Corporation

CEYON Technology

Digital Electronics Corparation
BIMNAR Elektronic AB
HONEYWELL

ROOTECH

IDEC Corporation

LENZE

BECKHOFF Automation

FASTRCH Cn.. | el hé
4_Back | B Next *® Cancel
Select Device [ = |
PLC Setting[ POWER FOCUS ]
Alias Name : BndIP: Auto  w
Interface : |Ethernet ~
Protocol 1 | OpenProtocol ~ Comm Manual

String Save Mode ; |First LH HL Change

[J use Redundancy
AND ~

Primary Option

> ExE e o e
Ethernet Protocol TCP

Timeout msec

Send Wait msec

4 Back + OK * Cancel
Settings Contents
TOP Model Check the display and process of TOP to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select "AtlasCopco”.
PLC Select an external device to connect to TOP.

Interface Protocol

POWER FOCUS Ethernet OpenProtocol

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting

TO,
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Ethernet]

— Set the TOP communication interface in TOP Design Studio.

Project Option

- Change HMI[H]

W saric Tl change PLCIC]

t {3 TOP Setting !
B 520%

Date / Time Sync.

Screen Option

E3 Delete PLCIDY

Unit Convert

e -2ﬁ;_”|;";d”‘é)sem”9 Project Option | Screen Change | HmiSetup || Global Lock & Touch | Project Style | Splash || PLC Buffer Sync.
W RFID (0} Use HMI Setup
v -4, Device Settin
\-:’."COMI(U)Q =eE Initialization | Edit |
™ COM2 () Project Setting ~
B¥ COM3 (0) HMIDisable=0
v g Ethernet (1) Project Name=New project
- PLC1: POWER FOCUS Start Mode=Menu
-~ Wireless {0) f?t;icsr::g Ne.=1
-4 USBDevice (0) Latch Set=0n~0
Communication Error Message =0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1
Contral Panel
i . o
System Devices ful Ethernet %
-Port
aamm B | - Ethernet Port ! ETH1 = 0 ?
il l (& Link Speed : duto -
PLC Security Dat e/T ime MAC Address @ 00:00:00:00:00:00
IP Address :|  192.168.0.100
Subnet Mask :  255.255.255.0
- Gateway !| 192, 168.0.1
e )
"I"" l—-— N [7] Default Gatewaw
Ethernet Serial HOM DNS (1) 3
ONS (2) ;]
" -Ethernet
- n\ Prinary IP :  192.168.0.100 ~
L A . Ping
e ; Cable Status
Diagnost ic File Ping
Wanager Bridae Hode : [1Use Bridae
Check duplicate | Apply | Cancel

* The above settings are examples recommended by the company.

Items TOP External device Remarks
IP Address 192.168.0.100 192.168.0.50
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1
* The above settings are examples recommended by the company.
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(2) Communication option setting

M [Project > Project Property > Device Setting > Ethernet > “"PLC1 : POWER FOCUS"]

ERI2 e B X
Touch Qperation Panel

— Set the options of the AtlasCopco POWER FOCUS Series Ethernet communication driver in TOP Design Studio.

Project Option

~ ] TOFP Setting
| L[ 5Y5:RD1520%
#8 Option Module Setting
- FieldBus (0)
.8 RFID (0)
Device Setting
5% COM1 (0)
£5® COM2 (0)
£5% COM3 (0)

FLC1 : POWER FOCUS

J
USBDevice {0)

- Change HMI[H] ' AddPLCIA] | THITal Change PLCIC | [T Delete PLCID)

PLC Setting[ POWER FOCUS ]

Alias Name :
Interface :
Protocol :

String Save Mode :

[pLci Bind IP :
Ethernet ~
CpenProtocol ~

First LH HL Change

[] use Redundancy

Primary Option
P

Ethernet Protocol

Ak

[2 | 8 Z| 0 F [

Ak

Comm Manual

TCP

Timeout msec

Send Wait msec

MID0052 Revision :

MIDOOS 1 Revision :

Apply Close

Items Settings Remarks
Interface Select “Ethernet”. Refer to "2. External
Protocol Select “OpenProtocol”. device selection”.
IP Enter the IP address of the external device.
Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.
Port Enter the Ethernet communication port number of the external device.
Timeout Set the time for the TOP to wait for a response from an external device.
Send Wait

Set the waiting time between TOP’s receiving a response from an
external device and sending the next

MID0052 Revision

Configure the revision for MID0052.

MID0061 Revision

Configure the revision for MID0061.
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3.2. Communication setting in TOP
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Control Panel] —

[Ethernet]

YNC
Yiewer 2
W =
F=ag
Ethernet
B
Diagnost ic
[System]

TOPRX — TOPRX0800S

Ethernet

- Port

Ethernet Port :

e o) =——

Link Seeed : -~
MAC Address @ 00:15:10:00:00:00
P Address : 192.168.0.100
Subnet Mask : 255.255.2585.0
Gateway :| 192.168.0.1

[ Default Gateway
DNS (1) ¢
DNS (2)
- Ethernet

Primary IP : | 182.168.0.100 |~|
ETH1 Mot connected

Cable Status
Bridge Mode :

[ Use Bridge

[Check duplicate] [ Apply I Cancel l

Dption

9

Sound

I~
—

MRAM
Analysis

Close

A 2021-08-31 02:03:27 PH

Items TOP External device Remarks
IP Address 192.168.0.100 192.168.0.50
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1
* The above settings are examples recommended by the company.
Items Description
IP Address Set the IP address of the TOP.
Subnet Mask Enter the subnet mask of the network.
Gateway Enter the gateway of the network.
External device connection manual for TOP Design Studio 6/ 10



TO,

(2) Communication option setting
M [Control Panel] — [PLC]

¥YNC
Yiewer

ERI2 e B X
Touch Qperation Panel

?} Ethernet

-Port
Ethernet Port

@ System
ll!l"
PLC

(e _He__[J
:[Auto |

71
00:15:1D:00:00: 00

192.168.0.100 Sound

MAC Address
IP Address :|

! Link Speed
S

Ethernet

Diagnost ic

Subnet Mask :| 255.255.255.0
= Gateway 1| 192.168.0.1 o —,
I “ [ Default Gateway -
DNS (1) ¢
. DNS (2) ¢
ﬂ - Ethernet
Primary IP : | 182.168.0.100 |~|
MRAM
Analysis

Cable Status : ETH1 Not connected

Dption

Bridge Mode : [J Use Bridge

TOPRX - TOPRX0800S

[System]

[Check dup| icate [ Apply l Cancel ]

Close

A 2021-08-31

* The above settings are examples recommended by the company.

02:03:27 PH

Items Settings Remarks

Interface Select “"Ethernet”. Refer to "2. External
Protocol Select “OpenProtocol”. device selection”.
IP Enter the IP address of the external device.

Ethernet Protocol

Select the Ethernet protocol between the TOP and an external device.

Port Enter the Ethernet communication port number of the external device.
Timeout Set the time for the TOP to wait for a response from an external device.
Send Wait Set the waiting time between TOP's receiving a response from an

external device and sending the next

MIDO0052 Revision

Configure the revision for MID0052.

MIDO0061 Revision

Configure the revision for MID0061.
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3.3 Communication diagnostics

TO BRI HE B X
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B Check the interface setting status between the TOP and an external device.

- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.

- Check if the port settings you want to use in [Control Panel > Ethernet] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not

- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

OK

Communication setting normal

Time Out Error

Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
configuration Connection cable name OK NG 1. System configuration
TOP Version information oK NG
Port in use oK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG 2. External device selection
Communication 3. Communication setting
diagnostics oK NG
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix OK NG ) )
Other detailed settings oK NG 4. External device setting
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
Check address range 5. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

- Refer to the manual of the external device and configure the communication options.
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5. Supported addresses

The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Address Size (Bit) Read/Write Remarks
START_BIT 1 Read *Note 1)
MID0052_VIN_NUMBER ASCII Read

MID0061_CELL_ID 16 Read

MID0061_CHANNEL_ID 16 Read
MID0061_TORQUE_CONTROLLER_NAME ASCII Read

MID0061_VIN_NUMBER ASCII Read

MID0061_JOB_ID 16 Read *
MID0061_PARAMETER_SET_ID 16 Read

MID0061_BATCH_SIZE 16 Read

MID0061_BATCH_COUNTER 16 Read

MID0061_TIGHTENING_STATUS 16 Read *Note 2)
MID0061_TORQUE_STATUS 16 Read *Note 3)
MID0061_ANGLE_STATUS 16 Read *Note 3)
MID0061_TORQUE_MIN_LIMIT 32 Read *Note 5)
MID0061_TORQUE_MAX_LIMIT 32 Read *Note 5)
MID0061_TORQUE_FINAL_TARGET 32 Read *Note 5)
MID0061_TORQUE 32 Read *Note 5)
MID0061_ANGLE_MIN 32 Read

MID0061_ANGLE_MAX 32 Read
MID0061_FINAL_ANGLE_TARGET 32 Read

MID0061_ANGLE 32 Read

MID0061_TIME_STAMP ASCII Read

MID0061_LAST_CHANGE_TIME ASCII Read

MID0061_BATCH_STATUS 16 Read *Note 4)
MID0061_TIGHTENING_ID 32 Read

*Note 1) SET when communication starts.

*Note 2) 0 : NOK 1:0K

*Note 3) 0. Low /1. OK/ 2 .High

*Note 4) 0: NOK 1:0K 2:notused

*Note 5) Must configure to show 2 decimal points at the object properties of the registered address.
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