Azbil Corporation
: SDC10/40G,DCP31/552,DMC10,CMC

Supported version  TOP Design Studio V1.4.3 or higher {Rl

CONTENTS

We would like to thank our customers for using M2l's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

‘ Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. External device setting Page 9

Describes how to set up communication for external devices.

5. cable table Page 10

Describes the cable specifications required for connection.

6. Supported addresses Page 11

Check for addresses that can communicate with an external

device.
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1. System configuration
The system configuration of TOP and “Azbil Corporation - SDC10/40G, DCP31/552, DMC10, CMC" is as follows:

Communication Communication

Series Link I/F )
method setting
Asbil 3. TOP
zbi -
) SDC10/40G,DCP31/552,DMC10,CMC - RS-485 communication 5. Cable table
Corporation ;
setting

W Connection configuration

+ 1:1 (one TOP and one external device) connection — configuration which is possible in RS232C/422/485 communication.

+ 1:N (one TOP and multiple external devices) connection — configuration which is possible in RS422/485 communication.

) (+] S—

{J ' «j | ?=;"j~] .........
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H

PLC select [COM1]

Filter : |[AII] v‘ Search : I:I

@ Model (O Vendor

Vendor
BONGSHIN LOADCELL ¢

FAMUC Co., Ltd.

MINEBEA Co., Ltd.

KORO TECHNOLOGY
ROBOSTAR

Ebmpapst

CoDeSys Automation Alliance
Ophir Optronics Solutions Ltd.
SERVOMEX

Tiger Optics, LLC

B &R Automation

Peripheral Device

OTHFR S Manufachire

4_Back | B Next *® Cancel

Select Device n

PLC Setting[ SDC10/406,DCP31/552,DMC10,CMC ]

Alizs Mame @ |PLCL

Interface : | Serial ~

Protocol : |Controller Peripheral Link  ~ Comm Manual
String Save Mode : |First LH HL Change

[ use Redundancy

Primary Option
Timeout 300 &|| msec
Send Wait msec
Retry

]

@ Back + OK * Cancel
Settings Contents
TOP Model Check the display and process of TOP to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select "Azbil Corporation”.
PLC Select an external device to connect to TOP.

Interface Protocol

SDC10/40G,DCP31/552,DMC10,CMC | Serial Controller Peripheral Link

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Option

-Change HMI[H]

' AddPLCIA] | THTE) Change PLCIC)

E3 Delete PCD)

I Ll ETDP =S Im Date / Time Sync. | Screen Option || Unit Convert
- Opﬁs“lggd”ﬁfem”g Project Option = Screen Change HmiSetup  Global Lock & Touch  Project Style = Splash  PLC Buffer Sync.
- FieldBus
i g RFID (0)
v -y Device Setting PO
‘:—’_' P Initialization | Edit |
-4 PLC1: SDC10/40G,DCP3] Project Setting -
% Com2 (0) HMIDisable=0
3% COM3 (0) Project Name =New project
- Ethernet (0) Start Mode=Menu
- Wireless (0) E:S‘sucs':ig Me.=1
W USBDevice (0) Latch Set=0n~0
Communication Error Message=0
USBErrorMessage =0
StorageErrorMessage=1
DatabaseMessage=1
Centrel Panel
. . T EED .
System m Devices |4 Service (=% 0ption
=" L /
e Serial
l Serial Port: @ COM1 v
PLC Security Dat e/ Time .
Signal Level

() R5-232C O R5-422(4) (@) R5-485(2)

; Baud Rate: 19200 =
.- B —
[ :
Data Bit: |8 -
Et hernet Serial HOK | .
Stop Bit: |1 ~
e Parity Bit: |[None -
[—Il = % Flow: |0ff
= ow:
. Fing
Diagnost ic File Fing Auto Search’ | Loopback Test
Manager
Apply Cance|
Items TOP External device Remarks
Signal Level (port) RS-485 RS-485
Baud Rate 19200 Fixed
Data Bit 8
Stop Bit 1
Parity Bit None

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [Project > Project Property > Device Setting > COM > "ASDC10/40G, DCP31/552, DMC10, CMC"]

— Set the options of the Computer Link communication driver in TOP Design Studio.

Project Option

- Change HMI[H] ' Add PLC[A] | THiTal Change PICIO | 1] Delete PLCID]

~ [} TOP Setting
| L[ 5Y5:RD1520%
Option Module Setting
8 FieldBus (0)
... RFID (0)
W - Device Setting

LY falal VEWAL]

- PLC1: SDC10/40G,DCP31

PLC Setting[ SDC10/ 40G,DCP31/552,DMC10,CMC ]
Alizs Name : [PLC1 |

Interface : |Serial ~

Protocol : |Controller Peripheral Link
String Save Mode : (First LH HL Change
W COM2 (0)

<% COM3 (0) [ use Redundancy

W Ethernet (0) AND -
® Wireless (0) S
-4 USBDevice (0) eOut

Primary Option
Timeout 200 &1 | msec

Send Wait

D

Comm Manual

£ >
Apply Close
Items Settings Remarks
Interface Configure the communication interface between the TOP and an external device. Refer to "2. External
Protocol

Configure the communication protocol between the TOP and an external device.

device selection”.

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

sending the next command request.

Set the waiting time between TOP’s receiving a response from an external device and
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3.2. Communication setting in TOP

* This is a setting method when "Use HMI Setup” in the setting items in "3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

e

o (‘-"‘" Serial

@ System DeViC‘ Serial Port: [COM1 -

m Signal Level
O RS-232C O RS-422(4) @ RS-485(2)

Run
‘ Security Date/1 Baud Rate: [ 19200
8

E3

v

[
|
|
)
)
|
J

|

Data Bit: | [

Vi Stop Bit: | 1 ]
] | 2 o

Ethernet Serial Parlty Blt' [None ‘v

Flow: [Off [v

IAuto Search] ‘Loopback TestJ

@)
)]

Diagnostic File Pin|
Manager [ Apply H Cancel ’

[System] Close

TOPRX - TOPRX0800S A  2021-08-31 03:29:02 PH
Items TOP External device Remarks
Signal Level (port) RS-485 RS-485
Baud Rate 19200 Fixed
Data Bit 8
Stop Bit 1
Parity Bit None

* The above settings are setting examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.

External device connection manual for TOP Design Studio 6/ 11



TO tHRIRUE &3y -
Touch Qperation Panel

(2) Communication option setting

B [Main Screen > Control Panel > PLC]

ot

System || Driver(COM1) |PLC1(SDC10/4OG,DCP31/552,DMC10,CMC) v’

Hun Interface [ Serial v
m "| Protocol | Control ler Peripher|~]
PLC sec] Timeout 300 3] msec

T Send Wait msec
| ({111 et T

D I:-
Ethernet Se| =

=)
=

Diagnost ic

[Systen] [ Diagnostic [ Apply ”Cancel J

e S

TOPRX — TOPRX0800S 2021-08-31 03-24:46 PH
Items Settings Remarks
Interface Configure the communication interface between the TOP and an external device. Refer to “2. External
Protocol Configure the communication protocol between the TOP and an external device. device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device

and sending the next command request.

ID (device address) | Configure the ID of target communication device.
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch "Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

- Refer to the manual of the external device and configure the communication options.
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This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. (The cable
diagram described in this section may differ from the recommendations of “SDC10/40G, DCP31/552, DMC10, CMC")

B 1:1 connection
TOP COM Port (9 pin)

COM PLC
Pin Signal Pin Cable connection .
Signal name
arrangement*Note 1) name number
1 5 RDA 1 DA
(© C) 2 DB
Q o) 3
6 9
RDB 4 —®
Based on
I SG 5
communication
SDA 6
cable connector
front, !
D-SUB 9 Pin male 8
(male, convex) SDB 9
*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
External
COM i
) device
X Cable connection
. Signal )
Pin arrangement Signal name
name
+ DA
— DB
MENIIES
101 -
+
B 1:N connection — Refer to 1:1 connection to connect in the following way.
TOP . . o PLC Cable connection and signal PLC
- Cable connection and signal direction - o -
Signal name Signal name direction Signal name
RDA DA DA
RDB DB DB
SDA —
SDB
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6. Supported addresses
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The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the
maximum address range used by the external device series. Please refer to each CPU module user manual and be

take caution to not deviate from the address range supported by the device you want to use.

Command

Bit address range

Word address range

Save location

D

0~65535.15

0~65535

INPUT PORT

Read-only, write-only, and read/write operations have different features depending on the address. Refer
to AZBIL user manual for details on each feature.
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