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MISUMI   

EXRS-C1 : SINGLE-AXIS ROBOT 

CONTROLLER 

 
 Supported version TOP Design Studio V1.0 or higher  
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We want to thank our customers who use the Touch Operation Panel. 
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 External device connection manual for TOP Design Studio 2 / 12 

1. System configuration 

The system configuration of TOP and “MISUMI EXRS C1” is as follows: 

 

Series Link I/F Communication method Communication setting Cable 

MISUMI :EXRS-C1 - RS–232C 
3. TOP communication 

setting 
5.1. Cable table 1 

 

■ Connection configuration 

 

ㆍ1:1 (one TOP and one external device) connection 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “MISUMI”. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

Misumi Exrs C1 Computer Link EXRS-C1 
 

 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [Project > Project Property > TOP Setting] → [Project Option > “Use HMI Setup” Check > Edit > Serial] 

– Set the TOP communication interface in TOP Design Studio. 
 

 
 

 
 

Items TOP External device Remarks 

Signal Level (port) RS-232C RS-232C Fixed 

Baud Rate 38400 Fixed 

Data Bit 8 Fixed 

Stop Bit 1 Fixed 

Parity Bit Odd Fixed 

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [Project > Project Property > Device Setting > COM > “Misumi Exrs C1”] 

– Set the options of the Computer Link communication driver in TOP Design Studio. 
 

 

 

Items Settings Remarks 

Interface Configure the communication interface between the TOP and an external device. Refer to “2. External 

device selection”. Protocol Configure the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

ASIS Total NUMBER Configure the total number of axes.  

NODE NO Configure the Node ID number.  

Ex) P01:001; the red text in the device address corresponds to the axis number. 

P01:001; when configuring as shown in the above figure, the number 1 next to the 

Node NO and below the AXIS NUMBER 1 becomes the Node ID.  
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [Main Screen > Control Panel > Serial] 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-232C RS-232C Fixed 

Baud Rate 38400 Fixed 

Data Bit 8 Fixed 

Stop Bit 1 Fixed 

Parity Bit Odd Fixed 

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [Main Screen > Control Panel > PLC] 
 

 

 

Items Settings Remarks 

Interface Configure the communication interface between the TOP and an external device. Refer to “2. External 

device selection”. Protocol Configure the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

ASIS Total NUMBER Configure the total number of axes.  

NODE NO Configure the Node ID number.  

Ex) P01:001; the red text in the device address corresponds to the axis number. 

P01:001; when configuring as shown in the above figure, the number 1 next to the 

Node NO and below the AXIS NUMBER 1 becomes the Node ID.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 

 

Refer to the vendor’s user manual to identically configure the communication settings of the external device to that of the TOP. 
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this section may differ from the recommendations of “MISUMI EXRS-C1”) 

 

5.1. Cable table 1 
 

■ 1:1 connection 

(A) TOP COM Port (9 pin) 

TOP COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1  1 DC12 

 

Based on 

communication 

cable connector 

front, 

MINI DIN8 Pin  

 

RD 2 5 RDX 

SD 3 3 TXD 

DTR 4 4 - 

SG 5 2 GND 

DSR 6 6 - 

RTS 7 7 E-STOP 

CTS 8 8 E-STOP 

 

9 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

(B) TOP COM Port (15 pin) 

TOP COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1  1 DC12 

 

Based on 

communication 

cable connector 

front, 

MINI DIN8 Pin  

  

RD 2 5 RDX 

SD 3 3 TXD 

DTR 4 4 - 

SG 5 2 GND 

DSR 6 6 - 

RTS 7 7 E-STOP 

CTS 8 8 E-STOP 

 

9 9  

 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 
 

Command Type Bit address range Word address range R/W Device description 

START 16bit - 0 W Positioning operation 

STOP 16bit - 0 W Operation stop 

ORG 16bit - 0 W Return-to-origin 

JOG+ 16bit - 0 W JOG movement_+ 

JOG- 16bit - 0 W JOG movement_- 

INCH+ 16bit - 0 W Inching movement+ 

INCH- 16bit - 0 W Inching movement- 

SRVO 16bit - 0 W Servo status change 

BRK 16bit - 0 W Brake status change 

RESET 16bit - 0 W Reset 

SETID 16bit - - W Automatic node number setting 

M 16bit 1–255.15 1–255 R/W Operation type 

P 32bit 1–255.15 1–255 R/W Position 

P_ 32bit 1–255.15 1–255 R/W Position 

S 16bit 1–255.15 1–255 R/W Speed 

S_ 16bit 1–255.15 1–255 R/W Speed 

AC 16bit 1–255.15 1–255 R/W Acceleration 

AC_ 16bit 1–255.15 1–255 R/W Acceleration 

DC 16bit 1–255.15 1–255 R/W Deceleration 

DC_ 16bit 1–255.15 1–255 R/W Deceleration 

Q 16bit 1–255.15 1–255 R/W Push 

Q_ 16bit 1–255.15 1–255 R/W Push 

ZL 32bit 1–255.15 1–255 R/W Zone (-) 

ZH 32bit 1–255.15 1–255 R/W Zone (+) 

N 32bit 1–255.15 1–255 R/W Near width 

J 16bit 1–255.15 1–255 R/W Jump 

F 16bit 1–255.15 1–255 R/W Flag 

T 16bit 1–255.15 1–255 R/W Timer 

K 32bit 1–138.15 1–138 R/W Parameter data writing 

TEACH 16bit 1–255.15 1–255 R/W Current position teaching 

COPY 16bit 0 0 R/W Point data copying 

DEL 16bit 0 0 R/W Point data deleting 

D 32bit - 0–20 R Status data reading 

IN 16bit 1,0–15 1 R Input/output information reading 

INB 16bit 0–15 - R Input/output information reading 

OUT 16bit 1,0–15 1 R Input/output information reading 

OUTB 16bit 0–15 - R Input/output information reading 

WIN 16bit - 0–3 R Word input/output information reading 

WOUT 16bit - 0–3 R Word input/output information reading 

OPT 32bit 0–31 0–2 R Option information reading 

OPTB 32bit 0–31 0–2 R Option information reading 

ALM 16bit - 1–32 R Alarm/warning information reading 

WARN 16bit - 1–32 R Alarm/warning information reading 
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7. alarm list 

Alarm No  Reset *1 Origin position *2 

02 DATA ERROR - - 

03 DATA RANGE OVER - - 

04 MONITOR MODE - - 

05 RUNNING - - 

06 MANUAL MODE - - 

41 SERVO OFF - - 

42 ORIGIN INCOMPLETE - - 

43 NO POINT DATA - - 

44 SOFTLIMIT OVER - - 

45 INTERLOCK - - 

46 STOP KEY - - 

47 PUSH MISTAKE - - 

48 ORG. MISTAKE - - 

49 SERIAL COMM. ERR. - - 

81 AC POWER DOWN Restart 
C1 : × 

C21/C22 : - 

82 ENCODER ERROR Restart X 

83 ABS. ENCODER ERR (C21,C22) Reset X 

84 IPM ERROR(C21,C22) Reset - 

85 OVERHEAT Reset - 

86 OVERLOAD Reset - 

87 OVERVOLTAGE Reset - 

88 LOW VOLTAGE Reset - 

89 POSITION ERROR Reset - 

8A ABS. BATTERY ERR(C21,C22) Reset X 

8B ABS. COUNT ERROR(C21,C22) Reset X 

8C ABS. ME. ERROR(C21,C22) Reset X 

8D ABS.OVERFLOW ERR(C21,C22) Reset X 

8E OVERCURRENT Reset - 

8F MOTOR CURRENT ERR. Reset - 

91 INT. COMM. ERROR Reset - 

92 CPU ERROR Reset - 

93 I/O FAULT Reset *3 - 

C1 EMERGENCY STOP Eliminate cause - 

C2 MOTOR POWER DOWN Eliminate cause - 

F1 ABS. BATT. LOW WARNIN(C21,C22) - - 

F2 PUSH WARNING - - 

F4 I/O ERROR - - 

*1. Indicates the alarm reset method 
*2. Indicates whether or not origin position is retained when alarm occurred. ( : Not retained) 
*3. Power must be turned off and then back on when using CC-Link or DeviceNet. 

 


