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BONGSHIN LOADCELL Co., Ltd. 

Digital Indicator BS Series 

Serial Driver 
 Supported version TOP Design Studio V1.4.8.17 or higher 

 

 

 

CONTENTS 

We want to thank our customers who use the Touch Operation Panel. 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of each 

device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 
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6. Supported addresses Page 13 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “BONGSHIN LOADCELL Digital Indicator BS Series“ is as follows. 

 

Series Model 
Communication 

method 
System setting Cable 

Digital Indicator 

BS-7220 

BS-7300 

BS-7300XL 

BS-5200 

BS-5205 

BS-3520 

BS-105 

BS-205 

BS-270 

BS-32 

RS–232C 

RS-422/485 

3. TOP 

communication 

setting 

4. External device 

setting 

5. Cable table 

 

■ Connectable configuration 
 

ㆍ1 : 1 (RS-232C/422/485) 
 

                         

 

 

ㆍ1 : N (RS-422/485) 
 

                                      ∙∙∙       

 

※ In Stream mode, only 1:1 communication is possible. 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 

 

 

Settings Contents 

TOP Model Check the display and process of TOP to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select BONGSHIN LOADCELL. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

Digital Indicator BS Series Serial Dedicated 
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 



 

 

External device connection manual for TOP Design Studio 4 / 14 

3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [Project] → [Property] → [TOP Setting] → [HMI Setup] → [Use HMI Setup Check] → [Edit] → [Serial] 

– Set the TOP communication interface in TOP Design Studio. 

 

 

 
 

Items TOP External device Remarks 

Signal Level (port) RS-232C / RS-422 / RS-485 RS-232C / RS-422 / RS-485  

Baud Rate 115200  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [Project] → [Property] → [PLC Settings > COM > PLC1: Digital Indicator BS Series] 

Set the communication options in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface Select “Serial”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next 
 

Retry Set the number of retries in case of communication failure.  

Model Select the model of the external device.  

Mode Select the communication method of the external device. *Note 1) 

Device ID Enter the equipment number of the external device.  

*Note 1) Stream: Select when the indicator data output setting is “Always send”. 

Command: Select when the indicator data output setting is “Transfer when data is requested”. 
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [Control Panel] → [Serial] 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-232C / RS-422 / RS-485 RS-232C / RS-422 / RS-485  

Baud Rate 115200  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [Control Panel] → [PLC] 
 

 

Items Settings Remarks 

Interface Select “Serial”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next 
 

Retry Set the number of retries in case of communication failure.  

Model Select the model of the external device.  

Mode Select the communication method of the external device. *Note 1) 

Device ID Enter the equipment number of the external device.  

*Note 1) Stream: Select when the indicator data output setting is “Always send”. 

Command: Select when the indicator data output setting is “Transfer when data is requested”. 
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 
 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the communication settings of the communication cable, TOP and external device. 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 
 

Set the RS-232C/422/485 interface by referring to the manual of the external device. 

 

The setting method differs depending on the model. Please refer to the manual provided by BONGSHIN LOADCELL Co., Ltd. for 

setting. 
 

Transmission mode*Note 1): Select 1 of “Always Send” (Stream mode) or “Send when data is requested” (Command mode). 

Transmission Speed: 115200 bps 

Data Bit: 8 

Stop Bit: 1 

Parity Bit: None 

 

*Note 1) If there is no setting item, set TOP to Stream mode. 
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5. Cable table 

We introduce the cable diagram for normal communication between TOP and the corresponding device. The cable table below may 

differ depending on the indicator model. For details, refeer to the manual provided by BONGSHIN LOADCELL Co., Ltd. 

 

■ RS-232C (1:1 connection) 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 
Signal name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1   

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RD 2 TXD 

SD 3 RXD 

DTR 4  

SG 5  

DSR 6  

RTS 7 GND 

CTS 8  

 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-422 (1:1 connection) 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 
Signal name  

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA(+) 1  TXD+  

 2 TXD- 

 3 RXD+ 

RDB(-) 4 RXD- 

SG 5 

 

SDA(+) 6 

 7 

 8 

SDB(-) 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-485 (1:1 connection) 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 
Signal name  

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA(+) 1  TRX+  

 2 TRX- 

 3 

 

RDB(-) 4 

SG 5 

SDA(+) 6 

 7 

 8 

SDB(-) 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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■ RS-485 (1:1 connection) 

TOP 

Cable connection 

External device 

Pin arrangement 
Signal 

name 

Signal 

name 
 

 

+  TRX+  

- TRX- 

SG 

 
 

 

■ RS-422  (1:N connection) – Refer to 1:1 connection to connect in the following way. 

TOP Cable connection and signal 

direction 

External device Cable connection and signal 

direction 

External device 

Signal name Signal name Signal name 

RDA(+)  TXD+ 

 

TXD+ 

RDB(-) TXD- TXD- 

SDA(+) RXD+ RXD+ 

SDB(-) RXD- RXD- 

 

■ RS-485  (1:N connection) – Refer to 1:1 connection to connect in the following way. 

TOP Cable connection and signal 

direction 

External device Cable connection and signal 

direction 

External device 

Signal name Signal name Signal name 

RDA(+)  TRX+  TRX+ 

RDB(-) TRX- TRX- 

SDA(+) 
  

SDB(-) 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

■ BS-7220/7300/7300XL 

Address Data Bit Word Size Read/Write Remarks 

D Weight D0.00~D0.31 D0~D0 32 bit   

STATUS Measurement status STATUS0~STATUS2 STATUS 16 bit  *Note 1) 

*Note 1) Measurement status when each bit is ON. 
 

Bit Status 

0 Stable 

1 Unstable 

2 Peak 

3~15 Reserved 

 

■ BS-205/105 

Address Data Bit Word Size Read/Write Remarks 

D Weight D0.00~D0.31 D0~D0 32 bit Read  

HOLD_ON Hold on HOLD_ON HOLD_ON - Write *Note 1) 

*Note 2) HOLD_OFF Hold off HOLD_FF HOLD_OFF - Write 

*Note 1) Address for sending commands to perform special functions. 

*Note 2) Available only in Command mode. 

 

■ BS-5200/5205 

Address Data Bit Word Size Read/Write Remarks 

D Weight D0.00 ~ D0.31 D0~D0 32 bit Read  

STATUS Measurement status STATUS0 ~ STATUS2 STATUS 16 bit Read *Note 1) 

GS/NT Measurement status GS/NT0 ~ GS/NT1 GS/NT 16 bit Read *Note 2) 

UNIT Unit - UNIT 2 letters Read *Note 3) 

*Note 1) Measurement status when each bit is ON. 
 

Bit Status 

0 Stable 

1 Unstable 

2 Over load 

3~15 Reserved 

 

*Note 2) Measurement status when each bit is ON. 
 

Bit Status 

0 Gross weight 

1 Net weight 

2~15 Reserved 

 

*Note 3) String data 
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■ BS-3520 

Address Data Bit Word Size Read/Write Remarks 

D Weight D0.00 ~ D0.31 D0~D0 32 bit Read  

STATUS Judgment STATUS0 ~ STATUS2 STATUS 16 bit Read *Note 1) 

LO Low Limit Value - LO 32 bit Read/Write 

*Note 2) 

 

HI High Limit Value - HI 32 bit Read/Write 

RY1 RY1 - RY1 32 bit Read/Write 

RY2 RY2 - RY2 32 bit Read/Write 

RY3 RY3 - RY3 32 bit Read/Write 

ZERO Zero action ZERO ZERO - Write 
*Note 3) 

*Note 4) 
HOLD_ON Hold on HOLD_ON HOLD_ON - Write 

HOLD_OFF Hold off HOLD_OFF HOLD_OFF - Write 

*Note 1) Judgment when each bit is ON. 
 

 

 

*Note 2) Float-type data 

*Note 3) Address for sending commands to perform special functions. 

*Note 4) Available only in Command mode. 

 

■ BS-270/32 

Address Data Bit Word Size Read/Write Remarks 

D Weight D0.00 ~ D0.31 D0~D0 32 bit Read  

STATUS Measurement status STATUS0 ~ STATUS2 STATUS 16 bit Read *Note 1) 

GS/NT Measurement status GS/NT0 ~ GS/NT1 GS/NT 16 bit Read *Note 2) 

UNIT Unit - UNIT 2 letters Read *Note 3) 

*Note 1) Measurement status when each bit is ON. 
 

Bit Status 

0 Stable 

1 Unstable 

2 Over load 

3~15 Reserved 

 

*Note 2) Measurement status when each bit is ON. 
 

Bit Status 

0 Gross weight 

1 Net weight 

2~15 Reserved 

 

*Note 3) String data. 

 

  

Bit Status 

0 L: RY1(LO) Relay action 

1 O: RY2(OK) Relay action 

2 H: RY3(HI) Relay action 

3 A: RY1(LO), RY2(OK) Relay action 

4 B: RY2(OK), RY3(HI) Relay action 

5 C: RY1(LO), RY3(HI) Relay action 

6 F: RY1(LO), RY2(OK), RY3(HI) Relay action 

7 N: RY1(LO), RY2(OK), RY3(HI) Relay OFF or No relay mode 

8~15 Reserved 
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※ Method to send commands to perform special functions 

 Addresses for sending special function performance commands are write-only and can be used by registering the object’s action to 

turn on or off bits of that address, or to enter any value. 

 

Ex) Send a hold setting command by pressing a square object. 

 1. After registering the square object, set “Condition” in “Effects and Actions” to [Event > Touch Down]. 

 2. Set the Action to [Bit > HOLD_ON Address Input > ON]. 

   (Set the maximum number of runs to 1, set the cycle, and set the delay to zero.) 

 3. Send the hold setting command to the indicator by pressing the square object in TOP. 
 

 
 

 

 


